httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "j k" <jonnyk...@gmail.com>
Subject Re: [users@httpd] Enable Apache with SSL
Date Thu, 17 May 2007 06:49:44 GMT
On 5/16/07, Malladi, Sasikanth <sasikanth.malladi@citi.com> wrote:
>
> All,
>
> Apologies if this is a FAQ and I should RTFM but I don't seem to find
> the right place to look.
>
> How do I enable my Apache 2 web server with SSL? I followed the advise
> here: http://docs.sun.com/source/819-5536-11/7_SSL_Apache.html#59207
> And here:
> http://developer.softwareag.com/tamino/documentation/ssl/ssl_support/apa
> che.htm
>
> Both seem similar but they didn't work. When I start it up with
> ./apachectl start (or startssl), it throws out the following message:
>
> [Tue May 15 17:24:27 2007] [error] (EAI 8)host/servname not known:
> Cannot resolve host name add --- ignoring!
>
> Also I'm getting and SSL certificate error:
>
> [Tue May 15 17:24:29 2007] [error] Init: Unable to read server
> certificate from file /usr/l
> ocal/apache2/conf/ssl.crt/server.crt
> [Tue May 15 17:24:29 2007] [error] SSL Library Error: 218529960
> error:0D0680A8:asn1 encodin
> g routines:ASN1_CHECK_TLEN:wrong tag
> [Tue May 15 17:24:29 2007] [error] SSL Library Error: 218595386
> error:0D07803A:asn1 encodin
> g routines:ASN1_ITEM_EX_D2I:nested asn1 error


the "host/servname not known:" would seem to indicate that your hostname is
not registered with DNS

I use gentoo and this worked for me:
http://gentoo-wiki.com/Apache_Modules_mod_ssl but on your distro it may be
quite different
you may also get more help here if you post the relevant parts of your
httpd.conf in case somone can spot a mistake

Mime
View raw message