httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lists <li...@jaqui-greenlees.net>
Subject Re: [users@httpd]: Can't find index.html
Date Wed, 23 May 2007 08:20:31 GMT
Richard Luckhurst wrote:
> Hi Boyle,
> 
> Wednesday, May 23, 2007, 4:23:28 PM, you wrote:
> 
>>> -----Original Message-----
>>> From: Richard Luckhurst [mailto:rluckhurst@resmaster.com] 
>>> Sent: Wednesday, May 23, 2007 1:09 AM
>>> To: users@httpd.apache.org
>>> Subject: [users@httpd] Can't find index.html
>>>
>>> Hi 
>>>
>>> This is probably a silly simple question. I have just set up 
>>> Apache 2.2.4 on a
>>> Fedora Core 4 box and am having a little trouble. When I 
>>> browse to the website
>>> url 
> 
> BO> "website url"? would that be http://server or http://server/?
> 
> In the case that is causing problems it is https://secure.resmaster.com/ that does not
work
> but https://secure.resmaster.com/index.html works.
> 
> Note that I have no trouble with http:// sites.
> 
>>> I find I get a messsage wanting to save or open the home 
>>> page. 
> 
> BO> That looks like a wrong mime-type.. Can you check the response header
> BO> (eg, via LiveHTTPHeaders extension in FireFox)?
> 
> Here is the output from LivrHTTPHeaders
> 
> https://secure.resmaster.com/
> 
> GET / HTTP/1.1
> Host: secure.resmaster.com
> User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309
Firefox/2.0.0.3
> Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
> Accept-Language: en-us,en;q=0.5
> Accept-Encoding: gzip,deflate
> Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
> Keep-Alive: 300
> Connection: keep-alive
> 
> HTTP/1.x 200 OK
> Date: Wed, 23 May 2007 07:24:25 GMT
> Server: Apache
> Last-Modified: Wed, 12 Apr 2006 05:26:05 GMT
> Etag: "10a8da-4ac-1380f540"
> Accept-Ranges: bytes
> Content-Length: 1196
> Keep-Alive: timeout=15, max=100
> Connection: Keep-Alive
> Content-Type: application/x-httpd-php

Do you have mod_php installed? Since this says apache is sending a php file.



> ----------------------------------------------------------
> https://secure.comodo.net/trustlogo/javascript/trustlogo.js
> 
> GET /trustlogo/javascript/trustlogo.js HTTP/1.1
> Host: secure.comodo.net
> User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309
Firefox/2.0.0.3
> Accept: */*
> Accept-Language: en-us,en;q=0.5
> Accept-Encoding: gzip,deflate
> Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
> Keep-Alive: 300
> Connection: keep-alive
> 
> HTTP/1.x 200 OK
> Date: Wed, 23 May 2007 07:24:58 GMT
> Server: Apache
> Last-Modified: Fri, 15 Dec 2006 15:12:45 GMT
> Etag: "22678-3e3b-424a61063f540"
> Accept-Ranges: bytes
> Content-Length: 15931
> Cache-Control: max-age=86400
> Keep-Alive: timeout=5, max=100
> Connection: Keep-Alive
> Content-Type: application/x-javascript

This is saying your https is sending javascript, so index.js is the file
it is sending. This should more commonly be text/plain for a javascript
file, then the browser will parse the file and execute the javascript.


~snip~

> The Directory Index directive is as follows.
> 
> DirectoryIndex index.html index.html.var index.shtml index.cgi index.php index.phtml
index.php3 index.htm home.html welcome.html

I see index.php so I'm guessing mod_php is installed.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message