httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Server Side Inluces Issue Apache 2.2.3
Date Thu, 26 Apr 2007 17:21:40 GMT
On 4/26/07, Chakrapani, Praveen Kumar Bellary (Contractor)
<PCHAKRAPANI@ftc.gov> wrote:
> Hi,
>
> We recently upgraded apache from 1.3.31 to apache 2.2.3.
>
> Older version works well with server side includes and parsing htm file
> to shtm files.
>
> However with new version when we try to access a link from another
> domain with a link to pointing to http://domain.gov/foo/foo.htm does not
> load the page. I am assuming when the url is accessed the browser treats
> the .htm as .shtm and load the page, the same link when used on older
> version works well.
>
> Any idea what could be the reason for parsing not to work in apache
> 2.2.3

>     AddType text/html .shtml
>     AddOutputFilter INCLUDES .shtml
>     AddType text/html .shtm
>     AddOutputFilter INCLUDES .shtm
>     AddHandler server-parsed .shtml
>     AddHandler server-parsed .shtm
>     AddType text/htm .shtm
> </IfModule>

This question is not at all clear. What exactly does "does not load
the page" mean? 404 error? The page is delivered but not parsed for
ssi?

In the latter case, you'll need
AddHandler server-parsed .htm

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message