httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Re Unable to get PAGE_COUNT working
Date Mon, 16 Apr 2007 22:52:58 GMT
On 4/16/07, Neville Hillyer <n.hillyer@open.ac.uk> wrote:
> This is still unresolved so I hope this additional information will enable
> somebody to tell me how to fix it. I have used a QPQ server for over 10
> years and am now moving all sites to Apache (1.3) on an Xserve. Everything
> appears to work OK except for PAGE_COUNT. All pages are parsed and most
> pages contain:
>
> <!--#echo var="LAST_MODIFIED"-->
> <!--#echo var="PAGE_COUNT"-->
>
> The date displays as expected but the hit counter only shows '(none)'.
>
> What have I done wrong or failed to do? Could moving the site root have
> caused a glitch? Where does Apache store the page counts?
>
> Any help would be much appreciated.

PAGE_COUNT is not an Apache or mod_include variable. It sounds like it
was a custom thing generated by "QPQ".

In general, I wouldn't recommend using a hit counter like that. It
makes your site look very 1990, among other problems. But if you
really want one, there are various ways to generate hit counters in
apache using cgi scripts or modules:
http://www.google.com/search?q=apache+hit+counter

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message