httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raju Chandran" <raj...@gmail.com>
Subject [users@httpd] Re: Trouble starting Apache HTTP Server
Date Wed, 25 Apr 2007 11:38:43 GMT
Hi all,

I am able to compile all modules as DSO using
./configure --prefix=PREFIX --enable-mods-shared=all

its now creating all the modules (.so extension) under the modules
directory.

Now I am again trying to start my server using 'httpd'

But this time I am getting error like this :

>> httpd -f /Volumes/DATA/Apache_224/conf/httpd.conf
Syntax error on line 65 of /DATA/Apache_224/conf/httpd.conf:
API module structure `auth_basic_module' in file
/Volumes/DATA/Apache_224/modules/mod_auth_basic.so is garbled - perhaps this
is not an Apache module DSO?

If I comment this , it goes to the next module and so on and to some stage
we get another error

"Cannot load /Volumes/DATA/Apache_224/modules/mod_auth_digest.so into
server: (reason unknown)"

Please help me at the earliest

Thanks
Raju



On 4/25/07, Raju Chandran <rajurc@gmail.com> wrote:
>
> Hi all,
> I am trying to configure my standalone Apache server 2.2 in my Mac OS
>
> I am able to compile and install Apache HTTP Server 2.2.4 source tree
> (downloaded for UNix) for my Mac OS server without enabling any features
> (modules)
>
> I followed the guidelines given
>
> http://httpd.apache.org/docs/2.2/install.html
>
>
> 1) I tried to start the server using "apachectl start"
>
> a)  but failing and showing the following :
>
>  Processing config directory: /private/etc/httpd/users/*.conf
>  Processing config file: /private/etc/httpd/users/abcde.conf
>  fopen: Permission denied
>  httpd: could not open error log file /private/var/log/httpd/error_log.
>
> I wonder why it is going to a different log path. I disabled the built-in
> Apache Webserver comes with MacOS. Is it causing the issue?
>
> b) I also tried "httpd -f ..../httpd.conf"
> but it is also failing
>
> Syntax error on line 114 of /Volumes/DATA/Apache_new/conf/httpd.conf:
> Invalid command 'Order', perhaps mis-spelled or defined by a module not
> included in the server configuration
>
> Please help me in the above and also help me in  how I can compile
> 'modules' into the binary and use them
>
> Thanks
> Raju
>
>
>

Mime
View raw message