httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jekillen <jekil...@prodigy.net>
Subject Re: [users@httpd] permissions on apxs
Date Sun, 01 Apr 2007 17:07:26 GMT

On Mar 31, 2007, at 6:18 PM, Kristopher Yates wrote:

> Hello Jeff,
>
> Are you configuring your PHP with ./configure 
> --with-apxs=/usr/local/sbin/apxs ?
>
> Specifying the full path to APXS in your configure may solve the 
> problem.
>
> Also, it sounds like you installed Apache using FBSD ports.  You may 
> want to install the port for PHP instead of compiling it.
>
> When using FBSD, I use ports for the most part, however, when it comes 
> to Apache and PHP, I prefer installing both by hand.  It seems to be 
> more manageable in the long run and tends to be a "smoother" install.
>
> If that doesn't work, let me know.  We'll need to move the 
> conversation to the php-general mailing list.  I'm not on the list but 
> can resubscribe if need be.
>
> Hope this helps,
>
> Kris
>
>> From: jekillen <jekillen@prodigy.net>
>> Reply-To: users@httpd.apache.org
>> To: users@httpd.apache.org
>> Subject: [users@httpd] permissions on apxs
>> Date: Sat, 31 Mar 2007 17:53:00 -0800
>>
>> Hello;
>> I am trying to install php with apache as a DSO
>> on FreeBSD v 6.2 . ./configure bails out complaining
>> about apxs permission denied. What could be the possible
>> causes?
>>
I did install apache by hand from tarball.
I discovered that I did not supply the full path to perl interpreter 
correctly.
When I fixed that problem the php compile went through make but
failed on make install because the file libphp5.so was not created.
It is nowhere on the system, as reported by the command line
find / -name libphp5.so -print. I know this is not the php list.
I was directed to the php install list and all I have been getting
from them are messages my ISP is finding viruses in.  I have
done this successfully on two other machines running FBSD 6.0
This machine is running v6.2. I have been bypassing ports for
technical reasons relating to my network setup.
I have tried this with Apache 1.3.37 and php 5.2.1 twice.
I went to php 5.1.2 and tried it. Same thing. Now I am
trying it with Apache 1.3.34. Same thing. It has to be some
thing with make or autoconf on this machine. I will go back
and do ./configure on php and read the output to see if
there is a clue there.
This is of great concern because this is supposed to be a
production server with ssl, gd, mcrypt, mysql  and all that. If I cannot
get php to work with Apache it is in vain.
Thanks for the reply.
Jeff K


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message