httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Douglas Rockney" <drock...@gmail.com>
Subject [users@httpd] Problems with loading a file - "LoadFile libxml2.so"
Date Tue, 10 Apr 2007 13:56:58 GMT
I'm attempting to use the mod_proxy_html.so module with IBM IHS (i.e. Apache
2.0.47) on Red Hat ES 3, but am running into difficulties even providing the
basics that it needs to run.  Specifically, if I attempt to load the file
libxml2.so as is expected by the module, HTTPD hangs.  I have confirmed that
libxml2.so exists and that is is valid (that is, it is the same binary as is
installed on our other Red Hat ES 3 servers).  I tried both this file and
the actual file it's a symbolic link to (libxml2.so.2.5.10) as options after
the LoadFile directive.

Here's some of the module/file directives in my httpd.conf:
----
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadFile /usr/lib/libxml2.so
LoadModule proxy_html_module modules/mod_proxy_html.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule deflate_module modules/mod_deflate.so
----
If I comment out the LoadFile... line, HTTPD states that mod_proxy_html.so
has undefined symbols.
If I also comment mod_proxy_html.so out, HTTPD loads with no issues.
If I comment out mod_proxy_html.so and enable LoadFile /usr/lib/libxml2.so,
HTTPD hangs.

When enabling libxml2.so, I set the LogLevel to debug and only see the
following in the error_log.  (Nothing ever prints in the access_log.)
[Mon Apr 09 14:30:03 2007] [notice] suEXEC mechanism enabled (wrapper:
/opt/IBMIHS/bin/suexec)
[Mon Apr 09 14:30:03 2007] [info] mod_unique_id: using ip addr <internal IP
address removed>
[Mon Apr 09 14:30:04 2007] [info] mod_unique_id: using ip addr <internal IP
address removed>

Thanks for any and all ideas, comments, further debugging pointers, etc.

-- Doug

Mime
View raw message