httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] SSL name based virtualhosts -- no, not the normal question!
Date Mon, 09 Apr 2007 19:32:48 GMT
Michael wrote:
> 
> I was sort of hoping "hmmm, they're just warnings, maybe it will be OK", but
> it appears not -- when I load the page, it gives me a "Connection
> Interrupted" or "Action Cancelled" (pick your browser) and I get this in the
> error.log:
> 
> [error] [client 192.168.0.4] Invalid method in request \x80L\x01\x03

That's an SSL/TLS HELO packet, being parsed as raw text.

> Does anyone have any ideas what I can do to fix it at all, or why it's
> happening? Or, if nothing else, how I can diagnose it further? :-)

Your first named virtual host will be used for the duration of the connection
handshake (because there is no named host yet during the connection).

Make sure your first named (default) host has the certs and SSL On.

Move those bogus entries to the bottom, see if that solves things.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message