httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lavoie,Alain [CMC]" <Alain.Lav...@ec.gc.ca>
Subject [users@httpd] Directory dissapearing when it's PW protected
Date Wed, 11 Apr 2007 21:11:56 GMT
Hello,

	I have a directory (public_data) where I turned on the Indexes
to see all the files and directories
in it. This directory is accessible by everyone, no restriction.
However, I want to protect with userName and Password
the directory "private" in it. I did:

<Directory "/web/public_data/private">
                Options Indexes
                IndexOptions FancyIndexing
                AuthType Basic
                AuthName "Password Protected"
                AuthUserFile /data/private/.htpasswd
                Require valid-user
                Order allow,deny
                Allow from all
</Directory>

But when I activated the authentication (AuthType, AuthName,
AuthUserFile, Require), the directory "private" dissapear from the list.
Is it possible to see the directory in the listing of public_data and be
password protected?

I'm using Apache-2.0.54 and mod_auth and mod_ssl are enabled. Also my OS
is Debian. The strange 
thing is I have the same configuration on Apache-1.3 and it's working.


	Thank you for your help!
	Levoy


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message