httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Haddon <...@greenleaftech.net>
Subject [users@httpd] 500 error page not showing?
Date Tue, 17 Apr 2007 08:16:26 GMT
Hi Folks,

I believe I have an issue with a custom 500 error page not showing. I
can simulate the error (or rather, cause the error) by stopping my
database server which then produces an "Operational Error" page. If I
look in my apache access logs I see an entry like this:

91.84.7.17 - - [16/Apr/2007:13:16:15 +0100] "GET / HTTP/1.1" 500 107 "-"
"Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201
Firefox/2.0.0.3 (Ubuntu-feisty)"

>>From what I can see this is showing that a 500 error is being recorded.
Interestingly I get nothing in the error log. In my apache config I
have:

ErrorDocument 500 /500.html

But the document isn't being shown, instead just the plain "Operational
Error" page. 

If I shut down my app servers, I can simulate/cause an 502 error fine
and the 502 error page I've created displays fine, and I get a message
like this in the error log:

[Tue Apr 17 07:45:06 2007] [error] (111)Connection refused: proxy: HTTP:
attempt to connect to 127.0.0.1:9999 (localhost) failed

Can anyone enlighten me?

Thanks, Tom

-- 


----------------------------------
Tom Haddon
mailto:tom@greenleaftech.net
m +1.415.871.4180
www.greenleaftech.net


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message