httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alberto Giménez" <lagime...@gmail.com>
Subject [users@httpd] ScriptAlias broken with VirtualDocumentRoot?
Date Wed, 28 Mar 2007 14:37:59 GMT
Hi, I have configured Mass Virtual hosting via a 'VirtualDocumentRoot'
directive at server context.

Before that directive I have the typical:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory /usr/lib/cgi-bin/>
    AllowOverride All
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>

I've noticed that cgi scripts are NOT working when I make a request to
the server (I get a 404 - Not found error).

 I suspect that the VirtualDocumentRoot makes in any way the server
not to use the ScriptAlias directive and then tries to find a physical
/cgi-bin/ directory inside the document root.

I've also tried to access some icons files (standard installation
again) to verify its not only cgi-related, but directive/configuration
related:

Alias /icons/ /usr/share/apache/icons/
<Directory /usr/share/apache/icons>
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

via www.myserver.com/icons/an_existing_icon.png

and I also get the 404 error.

I've been googling for that issue, but I didn't find anything. I also
tried Apache docs, and same result. I can't find a document which
explains the influences between directives (just got something about
the directive merging between <Directory>, <Location>, etc, but wasn't
at all what I am looking for).

Any idea?

TIA
-- 
Alberto Giménez

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message