httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robin-David Hammond <kb3...@pins.net>
Subject Re: [users@httpd] htpasswd problem adding user
Date Mon, 26 Mar 2007 18:30:09 GMT

the & has a special meaning within your shell. its NOT an htpasswd issue, 
if the shell manual is too big (normaly is) try using quotes or escaping 
the amp with a downstroke.


Robin-David Hammond  KB3IEN
50 West 17th Street
Ninth Floor
New York, NY 10011
+1 212 479.1700 x 1729


On Mon, 26 Mar 2007, Brian McCann wrote:

> Hi,
>
> When I try to add a new user with htpasswd on the command line, it takes every thing
after "f&"
> as a new command then  hangs waiting for some input after "Adding password for user jtest"
and when I enter
> Ctrl c it completes the command adding user "jtest" with a password "f"
>
> any help would be greatly appreciated
> Thanks,
> Brian
>
>
> [root@sirius1 ~]# htpasswd -b  /etc/opt/CollabNet_Subversion/conf/svn_auth_file jtest
f&5H%c
> [1] 23374
> -bash: 5H%c: command not found
> [root@sirius1 ~]# Adding password for user jtest
> [1]+  Done                    htpasswd -b /etc/opt/CollabNet_Subversion/conf/svn_auth_file
jtest f
> [root@sirius1 ~]#
>
> <mailto:brian.mccann@viziant.net>
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message