httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Hinse <l...@d0pefish.de>
Subject Re: [users@httpd] mod_proxy_balancer problem
Date Thu, 29 Mar 2007 21:21:41 GMT
PIRONET Benoit schrieb:
> I have changed my VirtualHost configuration like this:
> 
> <VirtualHost *:80>
>         ServerName lbtest.lifeonline.be
>         ServerAdmin benoit.pironet@gmail.com
>         ProxyPass / balancer://mycluster2 stickysession=PHPSESSIONID
> nofailover=On
>         <Proxy balancer://mycluster2>
>                 BalancerMember http://www.lifeonline.be:80
>         </Proxy>
>         ProxyPassReverse / htt://www.lifeonline.be:80
>         ErrorLog /var/log/http-balancer_error
> </VirtualHost>
> 
> But http://lbtest.lifeonline.be/img/logo.jpg  does not run but
> http://www.lifeonline.be/img/logo.jpg  runs :(
> 
> Do you know where I did the error ?

Hi,

just tested a similar setup, and it works for me. Which version of
apache are you using? Try the latest 2.2.4 - I had some trouble with
mod_proxy and 2.2.3.

ProxyPass /balancer-manager !

<Proxy balancer://mycluster>
  Order deny,allow
  Allow from all
  BalancerMember http://192.168.1.30:80 loadfactor=3
  BalancerMember http://192.168.1.31:80 loadfactor=3
</Proxy>

ProxyPass / balancer://mycluster/
ProxyPassReverse / http://192.168.1.30:80
ProxyPassReverse / http://192.168.1.31:80

<Location /balancer-manager>
  SetHandler balancer-manager
  Order Deny,Allow
  Deny from all
  Allow from 192.168.1
</Location>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message