httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Huisman <chris.huis...@pizza73.com>
Subject [users@httpd] Apache 2.2.3 prefork mpm mod_proxy_ajp
Date Mon, 19 Mar 2007 15:17:28 GMT
Hello,

I'm having a problem with mod_proxy_ajp, I am receiving the following 
error messages:

[Fri Mar 16 11:37:37 2007] [error] ajp_check_msg_header() got bad 
signature 420
[Fri Mar 16 11:37:37 2007] [error] ajp_ilink_receive() received bad header
[Fri Mar 16 11:37:37 2007] [error] ajp_read_header: ajp_ilink_receive failed
[Fri Mar 16 11:37:37 2007] [error] (120007)APR does not understand this 
error code: proxy: read response failed from url:8009 ( url)
[Fri Mar 16 13:28:45 2007] [error] (70007)The timeout specified has 
expired: ajp_ilink_receive() can't receive header
[Fri Mar 16 13:28:45 2007] [error] ajp_read_header: ajp_ilink_receive 
failed
[Fri Mar 16 13:28:45 2007] [error] (120006)APR does not understand this 
error code: proxy: read response failed from url:8009 (url)

in my apache error log. 

The following are my configuration files:

httpd.conf:

...
Timeout 300

KeepAlive On

MaxKeepAliveRequests 0
KeepAliveTimeout 15

<IfModule prefork.c>
StartServers 8
MinSpareServers 10
MaxSpareServers 25
ServerLimit 256
MaxClients 256
MaxRequestsPerChild 4000
</IfModule>

<VirtualHost url:80>
        ServerAdmin webadmin@xxx.com <mailto:webadmin@xxx.com>
        DocumentRoot /var/www/html
        ServerName www.url.com <http://www.xxx.com/>
        ServerAlias www.url.ca <http://www.xxx.ca/> www.url.biz 
<http://www.xxx.biz/>  url.com <http://xxx.com/> url.ca <http://xxx.ca/>

url.biz <http://xxx.biz/>
        ProxyPreserveHost On
        ProxyRequests Off

        Redirect 301 /cgi-bin/edd.cgi 
http://www.url.com/order/product.html 
<http://www.xxx.com/order/product.html>
        Redirect 301 /cgi-bin/menu.cgi 
http://www.url.com/order/product.html 
<http://www.xxx.com/order/product.html>

</VirtualHost>


In my tomcat server.xml, I have:

    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector address="url"
               port="8009"
               enableLookups="false"
               protocol="AJP/1.3"
               minSpareThreads="20"
               maxSpareThreads="200"
               maxThreads="1024"
               connectionTimeout="600000"
     />

and my proxy_ajp.conf:

ProxyPass /order ajp://url:8009/order
ProxyPass /dwr ajp://url:8009/dwr

The error messages come up intermittently maybe 5 times a day (although 
the ajp_check_msg_header() is a new one).  I believe what happens is the 
user gets to the secure checkout page, hits the order button and then 
the error shows up in the log file, but what the user gets is a blank 
page instead of the order confirmation page.  Could this be an SSL thing?

I've been through the mailing lists and seen some advice for people who 
are using the worker mpm, but nothing when using prefork.

Can anyone please, let me know what is going on (I'd like to understand 
why I get the error messages) and what to do prevent the error from 
coming up.

Thanks all for your consideration it is appreciated,

Chris.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message