httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gareth Howlett" <gareth.howl...@pivotalsys.com>
Subject [users@httpd] Apache on Win2K won't respond
Date Thu, 15 Mar 2007 17:58:03 GMT
Hi,

I'm new to the list but a long time user of apache - great piece of
software.  I've never needed this list before but I seem to have run
into a rather odd problem I can't solve.

I downloaded and ran the .MSI installer of 2.2.4 on one of my Win2K
boxes.  I moved IIS over to port 8080 and installed apache on port 80.
The installation went off without a hitch - the install log has no
errors at all.  The first thing I did was cranked the log level up to
debug and restart the server.  The error log now contains the following:

[Thu Mar 15 12:56:49 2007] [notice] Parent: Received restart signal --
Restarting the server.
[Thu Mar 15 12:56:49 2007] [notice] Child 4096: Exit event signaled.
Child process is ending.
[Thu Mar 15 12:56:49 2007] [notice] Apache/2.2.4 (Win32) configured --
resuming normal operations
[Thu Mar 15 12:56:49 2007] [notice] Server built: Jan  9 2007 23:17:20
[Thu Mar 15 12:56:49 2007] [notice] Parent: Created child process 3864
[Thu Mar 15 12:56:49 2007] [debug] mpm_winnt.c(481): Parent: Sent the
scoreboard to the child
[Thu Mar 15 12:56:49 2007] [notice] Child 3864: Child process is running
[Thu Mar 15 12:56:49 2007] [info] Parent: Duplicating socket 352 and
sending it to child process 3864
[Thu Mar 15 12:56:49 2007] [debug] mpm_winnt.c(599): Parent: Sent 1
listeners to child 3864
[Thu Mar 15 12:56:49 2007] [debug] mpm_winnt.c(402): Child 3864:
Retrieved our scoreboard from the parent.
[Thu Mar 15 12:56:49 2007] [debug] mpm_winnt.c(558): Child 3864:
retrieved 1 listeners from parent
[Thu Mar 15 12:56:50 2007] [notice] Child 4096: Released the start mutex
[Thu Mar 15 12:56:50 2007] [notice] Child 3864: Acquired the start
mutex.
[Thu Mar 15 12:56:50 2007] [notice] Child 3864: Starting 250 worker
threads.
[Thu Mar 15 12:56:51 2007] [notice] Child 4096: Waiting for 250 worker
threads to exit.
[Thu Mar 15 12:56:51 2007] [notice] Child 4096: All worker threads have
exited.
[Thu Mar 15 12:56:51 2007] [notice] Child 4096: Child process is exiting
[Thu Mar 15 12:56:51 2007] [notice] Child 3864: Starting thread to
listen on port 80.

So, everything seems fine... so far as I can see.

The problem is, the server _NEVER_ responds to a single get command.
Here's everything I tried so far:

- I've tried IE and Firefox, no difference... they just sit and wait
until they timeout.

- I've tried telneting to the server.  I get connected but any get
command I've tried results in no response and no disconnection... it
just sits there like I haven't typed anything.  If you stop the server
while telneted to it, you get disconnected - so I know it's the right
server.

- I've stopped the server, done a netstat (it wasn't there), restart the
server and done a netstat (now it's there).

- The access log is _completely_ empty... no help there.

- I've disabled all firewalls and networking protection - including
uninstalling my virus scanner.

- I've made sure IIS works on port 80 - so I know it's not a firewall
issue.

- I've tried reconfiguring the server for a different port (8081), no
difference.

- To be safe I've rebooted after messing with firewalls and uninstalling
virus scanners, etc.  (_the_ windows solution didn't work)

- I've even reinstalled the thing _several_ times.


I'm running out of ideas... anyone else have any I haven't thought of?

- Gareth

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message