httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chirouze Olivier" <olivier.chiro...@volvo.com>
Subject RE: [users@httpd] Status page: reading state
Date Tue, 06 Feb 2007 18:25:26 GMT
Hi,

I'm adding information to my own message... Hope someone will hear me!

I spent the day trying to test how the status page worked. I even had my
first look at the source code.
Apparently, modules that pre-process requests could make the request
being seen as "..reading.."
I think this might be a "bug" with mod_rewrite, or between it and
another one.

The thing is, it's not just a matter of look on the status page: the
whole story is, I'm trying to have a MaxClient per virtualhost. This is
supposed to work with some modules such as mod_bw
(http://bwmod.sourceforge.net/) or mod_cband (http://cband.linux.pl/). I
really believe they're serious modules, the later even has an example of
config with mod_rewrite.
But they both don't work for me, probably for the same reason that I see
"?" as virtual host on the status page. That's why I think if I can
manage to fix this, the modules will work (and I won't be fired ;-)

Thanks in advance,

Olivier

Olivier CHIROUZE
I&0 Infrastructure
Volvo Information Technology
 

> -----Original Message-----
> From: Chirouze Olivier 
> Sent: 06 February 2007 10:26
> To: 'users@httpd.apache.org'
> Subject: Status page: reading state
> 
> Hi,
> 
> This will seem like an obsession for me, but I have more 
> questions about the status page.
> I'm running Apache 2.0.58 on Solaris 5.9, as a reverse proxy. 
> [ This last point is probably key ]
> I thought the "..reading.." state meant "I'm reading client 
> request http headers".
> It seems it's not, or at least not when working as a proxy.
> 
> I've built up a simple configuration:
> Client => Apache Reverse Proxy => Web Server with a page that 
> waits 10 min
> 
> As expected, when accessing the web server through the 
> reverse proxy, a connection is held for 10 min.
> What I find really surprising is that the connection stays in 
> the "..reading.." state for 10 min!!! The client IP and 
> requested URL only appears on the status page when the 
> response has been sent to the client.
> 
> Another test makes me think that this works "as expected" in 
> a "non-proxy" mode: the URL appears as soon as the request is handled.
> 
> Do you think this is normal? Is there a way to change this behaviour?
> 
> Olivier
> 
> Olivier CHIROUZE
> I&0 Infrastructure
>  
> Volvo Information Technology                                  
>                                                            
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message