httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Philips <t...@rndgroup.co.nz>
Subject [users@httpd] ETags not included in Response-Headers:
Date Sun, 18 Feb 2007 00:28:22 GMT
Hi All,

I been requested to enable ETags for a customer on their Apache httpd
server (Version 2.0.52-28.ent.centos4) on CentOS 4.4 from RPM.

After researching the correct directive (FileETag) from the Apache core
documentation and several FAQ's I added:

FileETag MTime Size

To the main Apache configuration file in the server config.  After
reloading Apache (even stopping and starting) I don't see the suggested
ETAG header in the Response-Headers to the client.

I have tested the FileETag with INode as well without success. After
having no luck in the server config I added the directive to the
respective VirtualHost entry without luck (also tried .htaccess without
luck).  There are no errors in the ErrorLog for the server or virtual
host indicating any problem using the FileETag directive. Along with
different options in the Apache configuration file I have attempted to
enable FileETag on a totally different installation of CentOS 4.4 and
have tried several different browsers (as well as telnetting directly to
the Apache server) and still don't see the ETAG in the Response-Headers.

My research has indicated that once FileETag is enabled it should
automagically generate the ETAG based on the specified criteria and be
visible in the Response-Headers so either I have totally missed the boat
or my understanding of its usage is incorrect.

Look forward to anyone who could point me in the right direction.

Cheers.

-- 


Thanks
Tim Philips
RND GROUP LIMITED


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message