httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: [users@httpd] apache with mod_aspdotnet - vhosts
Date Fri, 09 Feb 2007 16:54:35 GMT
Morten Trydal wrote:
> Hello.
> 
> I have a problem getting virtual hosts working properly.
> 
> My vhosts file looks like this, which I think should be correct, although 
> I'm a programmer and not a server guy. Domain names are as you probably can
> see renamed for this post.
> 
> NameVirtualHost *:80
> 
> <VirtualHost *:80>
> DocumentRoot "c:/website"
> ServerName www.site1.com:80
> ServerAlias site1.com www.site1.com
> ErrorLog logs/site1-error_log
> CustomLog logs/site1-access_log common
> </VirtualHost>
> 
> <VirtualHost *:80>
> DocumentRoot "c:/wapsite"
> ServerName wap.site1.com:80
> ServerAlias wap.site1.com
> ErrorLog logs/site1_wap-error_log
> CustomLog logs/site1_wap-access_log common
> </VirtualHost>
> 
> Now onto what I think is my problem. What on earth to I write for
> AspNetMount / "c:/website" and 
> AspNetMount / "c:/wapsite" ?

Drop each correct aspnetmount into it's corresponding VirtualHost and
we would expect all to be well.  Right?  Normally you would have
a corresponding alias, but in this case, your DocumentRoot should
solve that issue.

> Obviously I can't set / for both of them, but I want to be able to type
> www.site1.com as well as wap.site1.com into the browser and have the
> addresses stay there.

Obviously?

> Any tips for me? Thanks.

Hope the hint helps.


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message