httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pranjal deka <pranjal.dek...@yahoo.co.in>
Subject RE: [users@httpd] mod_jk showstopper problem
Date Wed, 21 Feb 2007 08:34:43 GMT
hi john
 thanks for your advice.
 Right now i am facing one more problem.
   I am using apache2,jboss 1.0.4,suselinux10.
 I compiled apache and mod_jk file in the same  environment
 suselinux10.
   Then the connection between between apache and jboss
 was working fine.The i modified  mod_jk.conf and worker.properties
 file for setting up load balancing between two jboss server.
   After that i tried to connect apache with jboss the it showed the error----
 "STARTING HTTPD2 (PREFORK) HTTPD2-PREFORK: SYNTEX ERROR ON THE LINE 204 OF /ETC/APACHE2/HTTPD.CONF:
SYNTEX ERROR ON LINE 3 OF /ETC/APACHE2/MOD_JK.CONF: API MODULE STRUCTURE 'JK-MODULE' IN FILE
/USR/LIB/APACHE2/MOD-JK.SO IS GRABLED. PERHAPS THIS IS NOT AN APACHE MODULE DSO?"
 Then i nullify the changes i made on mod_jk.conf and worker.properties
 file,but the same error is coming while i am trying to connect apache2 with jboss.
 Please tell me what to do .this problem is killing me.
 regards,
 pranjal deka
 LINE
 

"John P. Dodge" <dodge@cruciate.ca.boeing.com> wrote: On Tue, 20 Feb 2007, pranjal deka
wrote:

> hi Owen
>  thanks once again.
>   Now i am a problem while compling mod_jk file in suselinux
>  for apache and jboss connection.
>  I followed the standard procedures but it can't complie
>  it is done as------
>      . command : ./buildconf.sh
>      error : line 11 aclocal : command not found
>                 line 13 autoheader : command not found
>                     line 15  automake :  command not found
>                line 17  autoconf : command not found
>     command :  make
>       error :  No Targets specified and no makefile found    stop
>      command :  cp /usr/src/jakarta-tomcat-connectors-1.2.15-src/jk/native/apache-2.0/mod_jk.so
  /usr/lib/apache2
>       error : cp cannot stat /usr/src/jakarta-tomcat-connectors-1.2.15-src/jk/native/apache-2.0/mod_jk.so
>    Please tell me what is the problem here.it is becoming a great issue.
>  Thanks in advance.
>  Regards,
>  Pranjal deka
>
>
> > Anyway, the problem is an inconsistent compilation - the
> > module was not
> > compiled with the same environment as httpd. Best advice would be to
> > recompile apache with the module.
> >
> > Rgds,
> > Owen Boyle
> >
> >
Try just using the configure script and apxs as is.

On my Solaris system I use:

cd /jk/native

export CC=gcc

./configure  --with-apxs=/opt/apache_2.2.4/bin/apxs \
             --with-java-home=/usr/j2se

gmake (Note: Use GNU make here)





----------------------------------------
"Mon aéroglisseur est plein d'anguilles"
John P. Dodge
Boeing Shared Services


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See  for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



 				
---------------------------------
 Here’s a new way to find what you're looking for - Yahoo! Answers 
Mime
View raw message