httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Swift" <steve.j.sw...@gmail.com>
Subject Re: [users@httpd] Problem with SUEXEC
Date Wed, 03 Jan 2007 07:00:07 GMT
I would interpret "search permission are missing on a component of the path"
to mean that some component of the directory path containing the file that
apache is trying to access does not contain an "x" permission that applies
to the apache userid or group.
However, that doesn't work for you (and I've never seen such an explicit
message from apache itself, so this may be coming from something else)

On 03/01/07, Dhika Cikul <dcikul@gmail.com> wrote:
>
> 2007/1/3, Steve Swift <steve.j.swift@gmail.com>:
> > In order for apache to access /home/mydomain/public_html/ (and
> presumably
> > something like index.html inside that directory) then the userid or
> group
> > that apache is running under needs both "r" and "x" access to each
> directory
> > /home /home/mydomain and /home/mydomain/public_html
>
> I have chmoded /home/mydomain and /home/mydomain/public_html to 755,
> but still get 403 permission denied
>
> > I've never understood why it works this way, but I've found out the hard
> way
> > that it does. Depending on your system there may be other access
> > restrictions in force, but the error message describes my suggestion
> rather
> > nicely.
>
> i didn't understood about the error message.
> [quote]
> [Fri Dec 29 14:11:45 2006] [error] [client 192.168.65.1]
> (13)Permission denied: access to / failed because search permissions
> are missing on a component of the path
> [/quote]
>
> what is the mean "search permission are missing on a component of the
> path"?
>
> > On 02/01/07, Dhika Cikul <dcikul@gmail.com> wrote:
> > >
> > > Dear,
> > >
> > > I have problem with apache installation at my machine, i compile
> > > apache with suexec support
> > >
> > > [quote]
> > > [root@server apache_1.3.37]# ./configure --prefix=/usr/local/apache
> > > --enable-suexec --suexec-caller=nobody --suexec-uidmin=99
> > > --suexec-gidmin=99
> > --suexec-safepath=/usr/local/bin:/usr/bin:/bin
> > > --suexec-userdir=public_html --enable-module=ssl --enable-shared=ssl
> > > --disable-rule=SSL_COMPAT
> > > [/quote]
> > >
> > > Installation process was succesfull, and this is the PHP configuration
> :
> > >
> > > [quote]
> > > [root@server php-4.4.4]# ./configure
> > > --with-apxs=/usr/local/apache/bin/apxs --with-mysql
> > --with-curl
> > > --with-gd --with-freetext=/usr/local/freetype
> > --with-gettext
> > > --enable-mbstring --enable-mbregex --enable-magic-quotes --with-xml
> > > --with-jpeg-dir=/usr/lib  --with-ftp --with-zlib
> > --enable-track-vars
> > > --enable-versioning --enable-memory-limit --with-pear --with-mcrypt
> > > --with-mhash
> > > [/quote]
> > >
> > > Both of that process was succesfully compiled, and i have tested with
> > phpinfo()
> > >
> > > The problem occur while i add virtualHost at httpd.conf
> > >
> > > [quote]
> > > <VirtualHost 192.168.65.128:80>
> > >     ServerAdmin webmaster@mydomain.net
> > >     DocumentRoot /home/mydomain/public_html/
> > >     User mydomain
> > >     Group mydomain
> > >     ServerName www.mydomain.net
> > >     ServerAlias domainku.net www.mydomain.net
> > >     CustomLog domlogs/mydomain.net-log combined
> > >     #ScriptAlias /cgi-bin/
> > /home/mydomain/public_html/cgi-bin/
> > > </VirtualHost>
> > > [/quote]
> > >
> > > While i add that virtualHost and i try to access mydomain.com, i get
> > > 403 permission error
> > >
> > > [quote]
> > > Forbidden
> > > You don't have permission to access / on this server.
> > >
> > > Apache/1.3.37 Server at www.mydomain.net Port 80
> > > [/quote]
> > >
> > > i have checked ownership and permission at /home/mydomain/public_html
> > > the ownership is mydomain.mydomain and permission is 755. I have try
> > > several times and still unsucessfull
> > >
> > > At apache error_log :
> > >
> > > [quote]
> > > [Fri Dec 29 14:11:45 2006] [error] [client 192.168.65.1]
> > > (13)Permission denied: access to / failed because search permissions
> > > are missing on a component of the path
> > > [/quote]
> > >
> > > anyone knows how to fix this problem??, i have tried with Apache2 and
> > > Apache1, and get same problem
> > >
> > > Thank's
> > > --
> > > Dhika Cikul
> > >
>
> >
> > --
> > Steve Swift
> >  http://www.swiftys.org.uk
>
>
> --
> Dhika Cikul
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
Steve Swift
http://www.swiftys.org.uk

Mime
View raw message