httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sander Temme <scte...@apache.org>
Subject Re: [users@httpd] Missing Mod_Access
Date Tue, 02 Jan 2007 01:50:41 GMT
Can Le,

On Jan 1, 2007, at 4:07 PM, Can Le wrote:

> Happy New Year to Sander Temme

Thank you, happy new year to you too (and to all readers of  
users@httpd).

> I do not have problem when I run my test.exe in Internet Explorer,  
> however, Firefox gave me these errors and asked me to down load  
> file test.exe, but Firefox did not run it on console:

The two browsers were written by different groups of programmers, and  
may respond differently under certain conditions.

> logs/error: [Mon Jan 01 16:58:04 2007] [error] [client 127.0.0.1]  
> malformed header from //script. Bad /header=<p>: testlcd83c.exe,  
> referer: http://localhost/cgi-bin/test1.cgi

So, your problem is with a CGI, not with a module.  This error  
message suggests that your testlcd83.exe (?) program writes HTML code  
to the browser without sending a proper HTTP header.  A properly  
formatted response has a set of HTTP headers, followed by the HTML  
code.  These are separated by a blank line.  If no headers are  
present, Apache thinks the HTML code your program writes (<p>) is  
intended to be a header, and will consider that invalid.

I am not sure what Apache does in such a situation, but the fact that  
you get the expected response in Explorer does suggest that the HTML  
code gets written to the browser, and it does not generate an error  
response.

As I said before, there are differences between various browsers.  I  
have the impression that Explorer does more inspection of the data  
that comes from the server, and makes its own decision on how to  
display it.  It looks like Firefox expects the (requisite) Content- 
type HTTP header, and in absence thereof offers to download the file.

> logs/access: 127.0.0.1 - - [01/Jan/2007:17:01:41 -0600] "GET /cgi- 
> bin/test1.exe HTTP/1.1" //200 190

This access log line does not correspond to the error log line you  
posted above: it has a different time and a different request  
(test1.exe vs. testlcd83c.exe). However, you can see that a 200 (OK)  
response was generated.

> I did not reboost my windows XP Home and Apache2, but I restarted  
> httpd.conf whenever I changed any line.
>
> Please tell me what should I have for:
>   LoadModule,

The requests you describe above seem to be CGI requests, and CGI  
programs are loaded from the file system.  They are not loaded  
through a LoadModule directive.

> or
> default type,
> or <meta http-equiv=.... >
>  or  :
> application/octet
> or
> text/html

A CGI program is responsible for the entire response, including  
headers.   Apache does not add a Content-type header to the CGI  
output.  Your program has to take care of that.

Regards,

Sander

> Thank you for helps
>
> Can le
>
> Sander Temme <sctemme@apache.org> wrote: Can Le,
>
> On Dec 29, 2006, at 7:16 PM, Can Le wrote:
>
> > I checked my httpd.conf and I am having mod_authz_host.so.
>
> Please tell us in detail about the error you are referring to:
>
> 1) Do you see it when you try to start the server, or when you access
> a URL on your server?
> 2) If the error occurs when you start the server: is there output  
> on the
> terminal window? What does it say? Is there error output in the
> error_log?
> 3) If the error occurs when you access a URL on your server: what does
> the error response say? Please turn off "Friendly Error Messages" in
> Internet Explorer, or use Firefox for testing. What information
> appears
> in the access_log and the error_log when Apache generates the error
> response?
>
> Please provide as much information as you can, so we can help you
> find the problem.
>
> S.
>
> -- 
> sctemme@apache.org http://www.temme.net/sander/
> PGP FP: 51B4 8727 466A 0BC3 69F4 B7B8 B2BE BC40 1529 24AF
>
>
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com


-- 
sctemme@apache.org            http://www.temme.net/sander/
PGP FP: 51B4 8727 466A 0BC3 69F4  B7B8 B2BE BC40 1529 24AF



Mime
View raw message