httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Johnson" <justinjohn...@gmail.com>
Subject Re: [users@httpd] Building Static Apache on AIX 5.2 with GCC
Date Fri, 05 Jan 2007 14:42:47 GMT
Well I'm getting further than I was before.  It seems my main problem
with LDAP not being recognized is that I was specifying
--with-ldap=yes instead of --with-ldap=/path/to/ldap/basedir.  So
after changing that I found that I need to first build apr and
apr-util, as documented at
http://httpd.apache.org/docs/2.2/install.html.

My new problem is that apr-util has a problem with a statically linked
ldap.  See below.

 /svn/static/build/httpd-2.2.3/srclib/apr-util>./configure \
 >      --prefix=$base_dir/apr-util-httpd \
 >      --enable-static=yes \
 >      --enable-shared=no \
 >      --with-ldap=$base_dir \
 >      --with-apr=$base_dir/apr-httpd
 checking build system type... powerpc-ibm-aix5.3.0.0
 checking host system type... powerpc-ibm-aix5.3.0.0
 checking target system type... powerpc-ibm-aix5.3.0.0
 checking for a BSD-compatible install... build/install.sh -c
 checking for working mkdir -p... yes
 APR-util Version: 1.2.7
 checking for chosen layout... apr-util
 Applying apr-util hints file rules for powerpc-ibm-aix5.3.0.0
 checking for APR... yes
   setting CC to "gcc"
   setting CPP to "gcc -E"
  setting CFLAGS to " -g -O2 -pthread"
  setting CPPFLAGS to " -U__STR__ -D_THREAD_SAFE -D_USE_IRS
-D_LARGEFILE64_SOURCE"
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for ldap support...
./configure[10557]: ac_cv_lib_/svn/static_ldap_init: is not an identifier

Any ideas on this one?

Thanks,
Justin

On 1/4/07, Eric Covener <covener@gmail.com> wrote:
> On 1/4/07, Justin Johnson <justinjohnson@gmail.com> wrote:
> > I tried adding those options but still get the same error; "could not
> > find an LDAP library".
> >
> > > I don't know why you're not finding ldap.  Do you have a library of
> > > the name libldap.a (or whatever suffix AIX uses, I forget) in that /
> > > svn/lib directory?  I have no idea why configure wouldn't find it there.
> >
> > Yes, libldap.a exists there.
>
>
> If you look at srclib/apr-utill/config.lig you can see the test
> programs autoconf is using to determine if an libldap.a is suitable.
>
> You might recognize the linker error and be able to fix it / modify
> the autoconf test / m4
>
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message