httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Graeme Walker" <graeme.walk...@gmail.com>
Subject Re: [users@httpd] Problem with Mod_Deflate & Virtual Hosts
Date Thu, 18 Jan 2007 09:22:58 GMT
Thanks for the reply, so I assume my configuration is correct? Looking at
the network setting in Firefox (About:config) The
network.http.accept-encoding setting has gzip,deflate in it, so it should be
sending it, but I'll check the headers. I just thought it was odd the fact
that ap_headers bit in the apache log, as I would have thought that would be
a sign of it working.

Cheers
Graeme

On 18/01/07, Boyle Owen <Owen.Boyle@swx.com> wrote:
>
> > -----Original Message-----
> > From: Graeme Walker [mailto:graeme.walker1@gmail.com]
> > Sent: Wednesday, January 17, 2007 10:55 PM
> > To: users@httpd.apache.org
> > Subject: [users@httpd] Problem with Mod_Deflate & Virtual Hosts
> >
> > Hi,
> >
> > I am trying to get mod_deflate working with my virtual hosts,
> > however it does not appear to be doing anything. I am using
> > Apache 2.2.4.
>
> The client has to tell the server that it can accept zipped content. It
> does this by sending a request header like:
>
> Accept-Encoding: gzip,deflate
>
> Is your client doing this? Try it on the command-line or get Firefox
> with LiveHTTPHeaders to check...
>
> Rgds,
> Owen Boyle
> Disclaimer: Any disclaimer attached to this message may be ignored.
>
>
> >
> > My Config is as follows:
> >
> > NameVirtualHost *:80
> > Listen 80
> >
> > <VirtualHost *:80>
> >   ServerName www.domain.com
> >   ServerSignature On
> >   DocumentRoot "D:/Website_Dev/cImages/cimage"
> >   AddOutputFilterByType DEFLATE text/html text/plain text/xml
> > image/jpg image/jpeg image/gif image/png application/xml
> > application/xhtml+xml
> >   DeflateFilterNote Input instream
> >     DeflateFilterNote Output outstream
> >     DeflateFilterNote Ratio ratio
> >     DeflateCompressionLevel 9
> >     LogFormat '%t %r %{outstream}n/%{instream}n
> > (%{ratio}n%%)' deflate
> >     CustomLog logs/deflate_main.log deflate
> >     LogLevel Debug
> > </VirtualHost>
> >
> > Within my deflate_main.log is showing no compression.
> >
> > The error log from apache is showing:
> >
> > [Wed Jan 17 21:48:28 2007] [debug] mod_headers.c(663):
> > headers: ap_headers_output_filter()
> > [Wed Jan 17 21:48:28 2007] [debug] mod_headers.c(663):
> > headers: ap_headers_output_filter()
> > [Wed Jan 17 21:48:28 2007] [debug] mod_headers.c(663):
> > headers: ap_headers_output_filter()
> >
> > This looks like it is appending the headers, but nothing is
> > happening. I am using FireFox 2.0.
> >
> > Any help would be much appreciated.
> >
> > Cheers
> > Graeme
> >
> >
> >
>
>
> This message is for the named person's use only. It may contain
> confidential, proprietary or legally privileged information. No
> confidentiality or privilege is waived or lost by any mistransmission. If
> you receive this message in error, please notify the sender urgently and
> then immediately delete the message and any copies of it from your system.
> Please also immediately destroy any hardcopies of the message. You must not,
> directly or indirectly, use, disclose, distribute, print, or copy any part
> of this message if you are not the intended recipient. The sender's company
> reserves the right to monitor all e-mail communications through their
> networks. Any views expressed in this message are those of the individual
> sender, except where the message states otherwise and the sender is
> authorised to state them to be the views of the sender's company.
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message