httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krist van Besien" <krist.vanbes...@gmail.com>
Subject Re: [users@httpd] Rewrite does not work
Date Thu, 11 Jan 2007 12:34:32 GMT
On 1/11/07, Peter Huesser <peter.huesser@psi.ch> wrote:
>
> > What might also  be an issue here is that reverse DNS doesn't work
> > properly.
> >
> > However, what you are trying to achieve might be better done
> > differently. See another post in this forum. You ought to set up two
> > virtual hosts, one on port 80 and one on port 443. Have a redirect to
> > the https host in the http host, and have your rewrite in the https
> > host config.
> >
> Hello Krist
>
> The tip with the two virtual hosts did not work either. In the meantime
> I guess it
> is a mailman problem (see my other postings). I have an etnry in the
> rewrite.log
> file which shows me that the RewriteCond I have is really used. But the used
> RewriteRule is not what I wrote in the httpd.conf file! At the moment I
> have the
> following entries in httpd.conf:
>
>   RewriteEngine On
>   RewriteCond %{REMOTE_HOST} \.domain\.ch$
>   RewriteRule ^/testtinfo/fea http://another.url.ch/
>
> The produced entries in rewrite.log are:
>
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (2) init rewrite engine
> with requested uri /testtinfo/fea
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (3) applying pattern
> '^/testtinfo/fea' to uri '/testtinfo/fea'
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#8140eb8/initial] (1) pass through
> /testtinfo/fea
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#808be78/subreq] (2) init rewrite engine
> with requested uri /fea
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#808be78/subreq] (3) applying pattern
> '^/mailman/listinfo/fea' to uri '/fea'
> 129.129.194.181 - - [11/Jan/2007:09:40:24 +0100]
> [server.psi.ch/sid#80c1cc8][rid#808be78/subreq] (1) pass through /fea
>
> which does not make any sense to me.

Is there a .htaccess file somehwere in your mailmain install? If so,
have a look in there...

Krist

-- 
krist.vanbesien@gmail.com
Bremgarten b. Bern, Switzerland
--
"...what you don't realize is that in the future Google WILL reach
sentience, will [have had] invent[ed] a time machine, and will [have
had] travel[ed] back in time to prevent Bill Gates... only to become
Bill Gates by accident because of a search engine optimization
miscalculation." (Comment on the Dilbert Blog)

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message