httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] apache serves cgi error as application/x-perl
Date Mon, 11 Dec 2006 20:57:03 GMT
On 12/11/06, William A. Rowe, Jr. <wrowe@rowe-clan.net> wrote:
> Boyle Owen wrote:
> >> -----Original Message-----
> >> From: Tony van der Hoff [mailto:lists_0504@vanderhoff.org]
> >>> This must obviously be a problem with my configuration, but
> >> having fiddled
> >>> about for a few days, I've not progressed much further. Changing the
> >>> mime.types file for .pl to text/html is effective, but it
> >> doesnt feel like
> >>> the correct solution to the problem.
> >
> > I rather think it might be... If the program works, the program itself
> > sets the mime-type. If it fails, the server returns a plain HTML file
> > and so has to decide for itself the mime-type. You must have set it to
> > application/x-perl somewhere.
>
> My guess is you are using mod_perl and you would be better off bringing
> this issue to their attention instead of the general httpd discussion list.

Or it could be this:
http://issues.apache.org/bugzilla/show_bug.cgi?id=37938

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message