httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "frank rittinger" <frank.rittin...@virtual-identity.com>
Subject [users@httpd] Problem using apache as a reverse proxy for https
Date Thu, 14 Dec 2006 10:56:40 GMT
Hello list,

I'm trying to get apache2 working as a reverse proxy. 

Regular HTTP requests just work fine, but I can't get it working for
HTTPS requests.

On startup of apache, I get the following error in the logs:
You configured HTTP(80) on the standard HTTPS(443) port!

Although, I just want to pass on the requests, do I still have to set up
SSL support properly? 

I have such a vhosts definition:

<VirtualHost 10.1.2.45:443>
      SSLProxyEngine on
	ProxyRequests Off
      ProxyPreserveHost On
      ProxyPass / https://10.1.2.27:443/
      ProxyPassReverse / https://10.1.2.27:443/
      ServerName test.com:443
</VirtualHost>

Apache 2.0.x on SuSE Linux 9.3. With modules proxy, ssl, proxy_connect,
proxy_http.

I searched the web for a while now and can't find any relevant answers.

Am I missing something, or does just not work?

Thanks in advance,

Frank Rittinger

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message