httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paul <p...@subsignal.org>
Subject [users@httpd] Re: Help with mod_proxy
Date Sat, 25 Nov 2006 09:46:15 GMT
Todd Nine schrieb:
[snip]

> Now, I am having a problem, and have a question.  First if all of the
> servers I am connecting to via the proxy server are not running, all of the
> virtual hosts that I'm proxying fail with the following error message for
> every back end server that's not running.  This seems to cause all proxying
> to fail.
Wait, you're saying if the backend is down proxying fails? What a
surprise...

> 
> [Fri Nov 24 14:07:26 2006] [error] (113)No route to host: proxy: HTTP:
> attempt to connect to 192.168.221.102:80 (192.168.221.102) failed
> 
> How can I set up the virtual host proxy to not cause an error if it cannot
> connect to the back end server?  Second, how can I set up a default "the
> server is under maintenance" page with the host name in it? 
I get a proxy error with a HTTP error code (cannot remember offhand). It
should be possible to set up a custom error page to catch that.

cheers
 Paul


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message