httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Directory settings
Date Wed, 22 Nov 2006 17:02:06 GMT
On 11/22/06, Susan Roesner RZ <sroe0999@rz.uni-hildesheim.de> wrote:
> Hi all,
>
> I use apache2.2.3 and in my httpd.conf I included a directories.conf. As soon as
> I include the "directories.conf" I get an error message: "You don't have
> permission to access / on this server". As soon as i remove the include I am
> able to see the webpages in those directories.
>
> As I am using the exact same configuration settings on my older apache and it
> works just fine there I am puzzled what I did wrong.
>
> The settings of my "directories.conf" are the following:
> <Directory /path/to/htdocs>
>     Options FollowSymLinks
>     AllowOverride None
>     Order allow,deny
>     Allow from all
> </Directory>
>
> <Directory /path/to/htdocs/ssl>
>     Options -Indexes Includes FollowSymLinks +ExecCGI
>     AllowOverride All
>     Order allow,deny
>     Allow from all
> </Directory>
>
> Please, could someone give me a hint what I did wrong?

Start by looking in the apache error log to see what the full problem
is.  One guess is that there is no index.html in the directory, so
apache is trying to do a directory listing but can't because you don't
have Indexes in the Options.  But the error log will give you the
truth.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message