httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John P. Dodge" <do...@cruciate.ca.boeing.com>
Subject Re: [users@httpd] Apache 2 + LDAP - valid user/pw not authenticated?
Date Mon, 13 Nov 2006 23:56:07 GMT
On Thu, 9 Nov 2006, Sohail Somani wrote:

> Hi,
>
> Invalid user: auth_ldap authenticate: user <bad_user> authentication
> failed; URI /mypaty [User not found][No such object]
> Valid user/invalid pw: user <good_user>: authentication failure for
> "/mypath": Password Mismatch
> Valid user/valid pw: No output from error log
>
> <Location /mypath>
>    AuthType basic
>    AuthName "Authentication domain"
>    AuthBasicProvider ldap
>    AuthzLDAPAuthoritative on
>    AuthLDAPURL "ldap://<host>/ou=Development,ou=Corporate
> Users,dc=financialcad,dc=com?sAMAccountName?sub?(objectclass=*)"
>    AuthLDAPBindDN "cn=<bind_user>,ou=Development,ou=Corporate
> Users,dc=financialcad,dc=com"
>    AuthLDAPBindPassword "<password>"
>    SSLRequireSSL
>    require valid-user
> </Location>
>
Try:

    AuthzLDAPAuthoritative off

This is the required setting when using "require valid-user"

----------------------------------------
"Mon aƩroglisseur est plein d'anguilles"
John P. Dodge
Boeing Shared Services


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message