httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fschnit...@vpcl.on.ca
Subject [users@httpd] Having problem getting Alias's to work....
Date Fri, 03 Nov 2006 17:37:14 GMT
Hi:

I'm new to apache and I am having some real troubles getting an alias to 
work. I'm using apache 1.3.29 on OpenBSD 3.8

I can get an alias to work if it's in the /var/www/ directory but I can't 
alias to anything elsewhere on the file system. I've chmod'd this and 
chgrp'd that but no luck.

Here is what I'm trying to do: I have a folder called "fred" in the root 
of the file system. Inside that folder is a file called index.html. This 
is what I'm trying to access.

In my httpd.conf:

Alias /fred "/fred/"
<Directory "/fred">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

>From a browser I can access the default apache page in /var/www/htdocs by 
pointing the browser to http://ServerName no problem.

If I try the following:

        http://ServerName/fred    or...
        http://ServerName/fred/   or...
        http://ServerName/fred/index.html

I get (respectively):

        The Webpage Cannot Be Found - 404 message in browser
        File does not exist: /fred/ - in error_log

        The Webpage Cannot Be Found - 404 message in browser
        File does not exist: /fred// - in error_log

        Forbidden - You don't have permission to access /fred/index.html 
on this server. - in browser
        (2)No such file or directory: cannot read directory for multi: 
/fred//

My file permissions on the directory are as follows:
        drwxr-xr-x   2 root    daemon      512 Nov  3 10:44 fred/

My file permissions within the directory are as follows:
        drwxr-xr-x   2 root  daemon   512 Nov  3 10:44 ./
        drwxr-xr-x  19 root  wheel    512 Nov  3 10:43 ../
        -r--r--r--   1 root  bin     3491 Nov  3 10:44 index.html

I've been playing around with various scenarios and configurations for 
days, but I can't get it figured out. Any help would be appreciated...


Thanks 



Fred
Mime
View raw message