httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boyle Owen" <Owen.Bo...@swx.com>
Subject RE: [users@httpd] Apache accessible only from localhost on Windows XP
Date Mon, 27 Nov 2006 15:57:44 GMT
> -----Original Message-----
> From: Lorenzo Marcon [mailto:lorenzo.marcon@startrekitalia.com] 
> Sent: Monday, November 27, 2006 4:47 PM
> To: users@httpd.apache.org
> Subject: [users@httpd] Apache accessible only from localhost 
> on Windows XP
> 
> Good morning,
> I have installed Apache 2.2.3 and php5 on Windows XP Professional SP2.
> My problem is that the webserver seems to work only if it's 
> being accessed 
> from the same machine it is installed on.
> If I try http://localhost from my browser all seems to work 
> perfectly, php 
> pages included.
> The other way round, I am nearly completely unable to access 
> the webserver 
> from any other PC of the same LAN in which the server is. If I digit 
> http://41.10.215.60 (that's my server ip), the connection times out.
> 
> It's not the first time that I install a webserver, so, 
> hoping to resolve 
> the problem, I tried the following operations:
> - Granted all permissions to Apache on my personal firewall 
> ---> No result
> - Completely disabled the personal firewall (Windows firewall 
> is disabled 
> too, I checked.) ---> No result
> - Tried a ping to the webserver address ---> It works
> - Tried a telnet to the webserver address  ---> Connection times out

A timeout suggests FW. I know you checked this.... but check the FW logs
for dropped connections.

> - Tried to change listening port of Apache ---> Behaviour 
> didn't change

I assume you *do* have something like "Listen 80"? BTW, I hope you don't
have "Listen 127.0.0.1" - once you list even one address in a Listen,
that is the *only* address that gets listened to and all others are
ignored.

Rgds,
Owen Boyle
Disclaimer: Any disclaimer attached to this message may be ignored. 

> 
> Note that on the machine running the webserver I have a dual 
> boot system. So 
> I tried to install Apache on the linux: the result is a 
> perfectly working 
> server machine. No problems of accessibility, even from the LAN.
> That makes me exclude network problems (according to this, 
> note that the 
> ping was successful). Problem is only related on running the 
> server on 
> Windows XP.
> 
> This is not all. I have to say, that *sometimes* I'm 
> successful in getting a 
> *single* page from Apache on Windows. This happens when I'm 
> not accessing 
> the server since a long time. But after the first successful 
> connection, 
> server cease to work again.
> To show you the behaviour I'm talking about, I'll post the 
> output of a 
> telnet connection attempt to Apache. You'll see a first successful 
> connection attempt, immediately followed by another identical 
> connection 
> attempt, this time being rejected:
> 
> ---------------------
> telnet 41.10.215.60 80
> Trying 41.10.215.60...
> Connected to 41.10.215.60.
> Escape character is '^]'.
> GET /
> <html><body><h1>It works!</h1></body></html>Connection
closed 
> by foreign 
> host.
> 
> telnet 41.10.215.60 80
> Trying 41.10.215.60...
> telnet: Unable to connect to remote host: Connection timed out
> ---------------------
> 
> I do not have success in connecting again after the first 
> attempt. The only 
> way I have to gain access again is to wait some time, or to 
> reboot the 
> machine.
> I'm experiencing exactly the same problem with a small test 
> client/server 
> application written by myself. That makes me exclude that the 
> problem is in 
> Apache.
> 
> Thank you in advance for your help. Sorry for any mistake in 
> my English. 
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP 
> Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
 
 
This message is for the named person's use only. It may contain confidential, proprietary
or legally privileged information. No confidentiality or privilege is waived or lost by any
mistransmission. If you receive this message in error, please notify the sender urgently and
then immediately delete the message and any copies of it from your system. Please also immediately
destroy any hardcopies of the message. You must not, directly or indirectly, use, disclose,
distribute, print, or copy any part of this message if you are not the intended recipient.
The sender's company reserves the right to monitor all e-mail communications through their
networks. Any views expressed in this message are those of the individual sender, except where
the message states otherwise and the sender is authorised to state them to be the views of
the sender's company.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message