httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinay Y S" <vinay...@gmail.com>
Subject Re: [users@httpd] WebDAV setup on Windows XP
Date Tue, 21 Nov 2006 19:20:12 GMT
Webdav in Windows products is broken beyond any hope. Even in Windows XP Pro
it doesn't work with certain combinations of updates and patches. Also, MS
Office products understand webdav. Even they don't work in all installations
as expected. Many a times they start talking FPSE.
Checkout http://greenbytes.com/
http://greenbytes.com/tech/webdav/webdav-redirector-list.html
http://greenbytes.com/tech/webdav/webfolder-client-list.html
http://greenbytes.com/tech/webdav/webdavfaq.html

Also look at Microsoft KB articles. Search on MSDN for "webdav" "web
folders" etc.
Overall, its quite hopeless.
For your specific problems there are hacks available on the net.
specifically a module that sits before auth and (de)mangles the username.

-- 
Vinay


On 11/22/06, Mark Lavi <mlavi@sgi.com> wrote:
>
> This is a well known "feature" of Windows XP Home and later editions.
>
> Workaround: use a port number after the domain, or use a trailing /. or
> a /# on any URL to use WebDAV properly in the setup wizard.
>
>     * e.g.: http://www.atarex.com:80
>     * e.g.: http://www.atarex.com/.
>     * e.g.: https://www.atarex.com/#
>
> Explanation: the :port number on the domain name, the trailing slash dot
> "/.", or slash pound "/#" at the end of the URL prevents the bug which
> interprets the resource as a SMB network drive.
>
> Additional editorial and background here:
> http://www.atarex.com/services/support/webdav-msft.shtml
>
> --Mark
> Mark Lavi, Enterprise Web Management Team @ SGI
> mailto:mlavi@sgi.com || phone:+1-650-933-7707
> -----Original Message-----
> From: William A. Rowe, Jr. [mailto:wrowe@rowe-clan.net]
> Sent: Monday, November 20, 2006 1:42 PM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] WebDAV setup on Windows XP
>
> You seem to be confusing auth_sspi (ntlm) auth with basic auth.  Or it's
> an issue with your client - do you have another non-Microsoft dav client
> to try?  And see conf/extras/httpd-dav.conf for an example.
>
> Steve Pfister wrote:
> > Sorry if this is a FAQ... I'm trying to set up an Apache server
> (2.2.3, I
> > think) on XP and I'd like to setup WebDAV on it. Is there any
> > documentation on this? I can't seem to authenticate... I've got an
> > htpasswd generated authentication file, but it keeps wanting the
> > username in the form machinename\username. I'm not sure how to go
> beyond
> > this point.
> >
> >
> >
> > Thank you!
> >
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
Vinay Y S
http://vinay-ys.blogspot.com

Mime
View raw message