httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sharath reddy" <reddy....@gmail.com>
Subject Re: [users@httpd] child process launching the child process in prefork
Date Fri, 17 Nov 2006 17:42:28 GMT
Hi Joshua,

i am not using any piped modules and here are the compiled
modules list.....,

Compiled in modules:
  core.c
  mod_access.c
  mod_auth.c
  mod_include.c
  mod_log_config.c
  mod_env.c
  mod_setenvif.c
  mod_proxy.c
  proxy_connect.c
  proxy_ftp.c
  proxy_http.c
  prefork.c
  http_core.c
  mod_mime.c
  mod_status.c
  mod_autoindex.c
  mod_asis.c
  mod_cgi.c
  mod_negotiation.c
  mod_dir.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_so.c

Thanks,
Sharath


On 11/17/06, Joshua Slive <joshua@slive.ca> wrote:
>
> On 11/17/06, sharath reddy <reddy.web@gmail.com> wrote:
> > Hi All,
> >
> > I am using apache 2.0.55(wirh prefork) on Linux,
> >
> > In normal conditions single control process is responsible for launching
> > child processes which listen for connections and serve them when they
> > arrive...
> >
> > Problem: the child processes are also launching child processes, so when
> i
> > started(restarted) apache, it is starting with 15 ( or more) servers,
> even
> > though the StartServers is 5. Further more, to serve one request the
> total
> > processes are going as high as 48.
> >
> > Can somebody tell me about the solution or where it went wrong? Is it
> > problem with Apache or OS (Linux) ?
>
> Exactly what apache modules are you using?  Are you using piped logs?
>
> Joshua.
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message