httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Kellogg <apa...@nwlocation.com>
Subject [users@httpd] SSL config question
Date Mon, 20 Nov 2006 22:47:40 GMT
I need some help getting SSL to work in conjunction with auth.  Using the 
following vhost entry, SSLng works fine if we set the following config up 
with <VirtualHost 10.1.2.98:443>.  However, we only want ssl used when 
accessing the /kna directory so we left off the ssl port on the VirtualHost 
directive and included SSLReguire within that directory.   It does not 
work, Apace errors with " SSl connection required".

Any help is appreciated!





<VirtualHost 10.1.2.98>

     ServerAdmin nathan@nwlocation.com
     DocumentRoot c:/nwls/htdocs
     ServerName nwlocation.com
     ServerAlias www.nwlocation.com
     ErrorLog c:/nwls/logs/error_log
     CustomLog c:/nwls/logs/access_log common


  SSLEngine on		
  SSLCertificateFile    c:/www/ssl/server.crt
  SSLCertificateKeyFile c:/www/ssl/server.pem
  SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

<Directory "c:/nwls/htdocs/">
     Options FollowSymLinks
     AllowOverride None
     Order allow,deny
     Allow from all
</Directory>


<Directory c:/nwls/htdocs/kna/>

AuthType Basic
AuthName "Authorization Required"
AuthUserFile c:/nwls/passwords
Require user test
SSLRequireSSL

</Directory>

</VirtualHost>


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message