httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel E <emmanue...@gmx.net>
Subject Re: [users@httpd] Apache 2.2.3 Memory Usage
Date Tue, 21 Nov 2006 04:49:13 GMT
I dont know if youre on Windows, but i had to give up mod_perl on 
windows because of excessive memory usage (probably some leak). the 
machine used to slow down to a crawl after a day of apache running 
continuously. if you want to use perl but without mod_perl you could 
just do it like apache calls any script in cgi-bin.

Chris wrote:
> On 20/11/06, Joshua Slive <joshua@slive.ca> wrote:
>> On 11/20/06, Strader, William A. <WILLIAM.A.STRADER@saic.com> wrote:
>> > Well it does seem like mod_perl is a a RAM users... I commented it 
>> out and
>> > instead of 120mb RAM it is using 60mb RAM... Any suggestions on 
>> what I can
>> > do to make mod_perl not use so much ram... I have it running cause 
>> I am
>> > testing out a CMS system called WebGUI... Maybe I should just get 
>> used to
>> > that amount of ram being used...
>>
>> Even 60mb of RAM is on the absurd side, except for very specific
>> cases.  You should keep removing modules until you get down to
>> something in the low double digits.
>>
>> As far as mod_perl goes, I'm not an expert.  Obviously there is too
>> much stuff getting loaded at startup.  You should ask over on the
>> mod_perl list, or in a support forum for WebGUI.
>>
>> Joshua.
>>
>> ---------------------------------------------------------------------
>> The official User-To-User support forum of the Apache HTTP Server 
>> Project.
>> See <URL:http://httpd.apache.org/userslist.html> for more info.
>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
>> For additional commands, e-mail: users-help@httpd.apache.org
>>
>>
>
> Hi I use apache 1.3 as well as 2.2.3 so this is off topic since this
> is for 2.2.3 but I have just noticed my processes use in excess of
> 100meg per child, I run eaccelerator which I know accounts for some of
> this 32meg so this would leave around 80 meg per process without
> eacellerator, I always thought this was normal and would explain why
> on a box with 2 gig of ram I cant get anywhere near the amount of
> child processes others reach without using swap.
>
> Chris
>
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server 
> Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>   "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message