httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lorenzo <l.bolz...@gmail.com>
Subject [users@httpd] Problem with POST method
Date Tue, 14 Nov 2006 17:20:48 GMT

Hi all.
I'm sending a simple http POST request and the browser hangs waiting for 
a reply.

This is my test page

<html>
        <form action="/post.html" method="post">
                <input type="text" name="aaa"/>
                <input type="text" name="bbb"/>
                <input type="submit"/>
        </form>
</html>

I have this problem both with httpd-2.2.3 and 2.0.46.
I have no problems with GET requests.
KeepAlive is turned off.

If I turn KeepAlive on things are a little different: if I request the 
test page and quickly submit the form there is no problem. If I wait 
enough to make the connection time out the request remains pending.

I think this is too big to be an apache problem, so I suspect there is 
something in os/firewall configuration to fix.

Have you ever seen something like this? Do you have any ideas?


Thanks, Bye

Lorenzo



---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message