httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik van Dam <e.van....@nedstat.com>
Subject [users@httpd] Re: httpd 2.2.3 compile failures
Date Mon, 06 Nov 2006 14:26:58 GMT
Erik van Dam wrote:
> Dear All,
> 
> I'm trying to compile apache 2.2.3 with the following options:
> 
> "./configure" \
> "--prefix=/usr/local/apache" \
> "--with-mpm=prefork" \
> "--disable-include" \
> "--disable-cgid" \
> "--disable-imap" \
> "--disable-userdir" \
> "--enable-mods-shared=cgi ssl expires" \
> "--enable-so" \
> "--sysconfdir=/usr/local/apache/conf" \
> "--enable-headers" \
> "--with-dbm=db43" \
> "--with-included-apr" \
> "--enable-proxy" \
> "--enable-proxy-ajp" \
> "--enable-rewrite" \
> "--enable-deflate" \
> "$@"
> 
> 
> The configure goes fine but then i run make and it stops at:
> 
> make[1]: Entering directory `/root/httpd-2.2.3/support'
> make[2]: Entering directory `/root/httpd-2.2.3/support'
> /root/httpd-2.2.3/srclib/apr/libtool --silent --mode=compile gcc -g -O2 
> -pthread    -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE   
> -I/root/httpd-2.2.3/srclib/pcre -I. -I/root/httpd-2.2.3/os/unix 
> -I/root/httpd-2.2.3/server/mpm/prefork -I/root/httpd-2.2.3/modules/http 
> -I/root/httpd-2.2.3/modules/filters -I/root/httpd-2.2.3/modules/proxy 
> -I/root/httpd-2.2.3/include -I/root/httpd-2.2.3/modules/generators 
> -I/root/httpd-2.2.3/modules/mappers -I/root/httpd-2.2.3/modules/database 
> -I/root/httpd-2.2.3/srclib/apr/include 
> -I/root/httpd-2.2.3/srclib/apr-util/include 
> -I/root/httpd-2.2.3/modules/proxy/../generators 
> -I/root/httpd-2.2.3/modules/ssl -I/root/httpd-2.2.3/modules/dav/main 
> -prefer-non-pic -static -c htpasswd.c && touch htpasswd.lo
> /root/httpd-2.2.3/srclib/apr/libtool --silent --mode=link gcc -g -O2 
> -pthread        -o htpasswd  htpasswd.lo   -lm 
> /root/httpd-2.2.3/srclib/pcre/libpcre.la 
> /root/httpd-2.2.3/srclib/apr-util/libaprutil-1.la -lexpat 
> /root/httpd-2.2.3/srclib/apr/libapr-1.la -lrt -lcrypt -lpthread -ldl
> /root/httpd-2.2.3/srclib/apr-util/.libs/libaprutil-1.so: undefined 
> reference to `apr_dbm_type_db'
> collect2: ld returned 1 exit status
> make[2]: *** [htpasswd] Error 1
> make[2]: Leaving directory `/root/httpd-2.2.3/support'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/root/httpd-2.2.3/support'
> make: *** [all-recursive] Error 1
> 
> 
> The reason it goes wrong is due the variable "--with-dbm=db43" anybody 
> why this is and how to solve it?
> 

Fixed,

Added

"--with-berkeley-db" and everything got out fine.


-- 
Erik van Dam		| Nedstat BV
e.van.dam@nedstat.com	| Dalsteindreef 30
+31 (0) 6 22 31 32 45	| 1112 XC  DIEMEN

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message