httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary D. Margiotta" <g...@tbe.net>
Subject [users@httpd] httpd 2.2.3 build issue
Date Mon, 06 Nov 2006 16:56:56 GMT
I'm running into an issue when trying to compile httpd from source on a 
RHEL 4.0 Update2 system, 32-bit, running as a VMWare image:

Linux localhost.localdomain 2.6.9-22.EL #1 Mon Sep 19 18:20:28 EDT 2005 
i686 i686 i386 GNU/Linux

(yes, I know I haven't set my hostname, this was a quick clone for a build 
test)


gawk -f /inet/src/httpd-2.2.3/srclib/apr/build/make_var_export.awk 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_thread_mutex.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_env.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_poll.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_fnmatch.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_global_mutex.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_pools.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_want.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_file_io.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_version.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_mmap.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_dso.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_thread_proc.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_errno.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_shm.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_network_io.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_signal.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_user.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_support.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_atomic.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_random.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_thread_cond.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_thread_rwlock.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_getopt.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_inherit.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_strings.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_general.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_proc_mutex.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_tables.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_ring.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_file_info.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_allocator.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_portable.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_hash.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_time.h 
/inet/src/httpd-2.2.3/srclib/apr/include/apr_lib.h > export_vars.c
gawk: fatal: no (known) protocol supplied in special filename 
`/inet/src/httpd-2.2.3/srclib/apr/build/make_var_export.awk'
make[3]: *** [export_vars.c] Error 2
make[3]: Leaving directory `/inet/src/httpd-2.2.3/srclib/apr'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/inet/src/httpd-2.2.3/srclib/apr'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/inet/src/httpd-2.2.3/srclib'
make: *** [all-recursive] Error 1

The file /inet/src/httpd-2.2.3/srclib/apr/build/make_var_export.awk does 
exist, and is not garbage.

Here's my configure options (which completes without errors):

./configure -C \
         --prefix=/inet/apps/apache-2.2.3 \
         --enable-so \
         --enable-mods-shared="all" \
         --disable-deflate \
         --enable-ssl --with-ssl=/usr \
         --enable-cache --enable-disk-cache --enable-mem-cache \
 	--enable-file-cache \
  	--enable-proxy --enable-proxy-ajp \
         --with-mpm=prefork \
         --with-program-name=inet-httpd


The compile worked fine the first time on the same VM image, but now on 
subsequent builds can't seem to get past this part.  I'm looking for any 
cruft in the system which may have been left over from any previous 
compile/install, but no success yet.

Googling came to nothing useful yet for me.

-Gary

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message