httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rod R" <scruffe...@verizon.net>
Subject RE: [users@httpd] Reverse Proxy woes
Date Thu, 23 Nov 2006 15:19:58 GMT
Thanks for the reply.  If you would please look at the complete request you
would see that I am using AJP to communicate to one host and http to
communicate with the other.  The AJP connection is working fine, it's the
http to the IIS6 machine that's problematical.

ProxyRequests Off
ProxyPreserveHost off
<Proxy *>
Order Deny,Allow
Allow from all
</Proxy>
ProxyPass /portal ajp://machine2:7001/portal 
ProxyPassReverse /portal ajp://machine2:7001/portal 
ProxyPass /imageserver http://image:7002/imageserver ttl=128 retry=300
ProxyPassReverse /imageserver http://image:7002/imageserver
 

-----Original Message-----
From: William A. Rowe, Jr. [mailto:wrowe@rowe-clan.net] 
Sent: Wednesday, November 22, 2006 7:17 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Reverse Proxy woes

"The backend image server is running IIS6"

IIS speaks http:, only Tomcat (and perhaps some Tomcat derived app servers)
can speak ajp:.


Rodolfo Rosado wrote:
>  
> 
> -----Original Message-----
> From: scruffeone@verizon.net [mailto:scruffeone@verizon.net]
> Sent: Friday, November 17, 2006 4:39 PM
> To: users@httpd.apache.org
> Subject: [users@httpd] Reverse Proxy woes
> 
> Hi All,
> 
>     Apache 2.2 -----reverse proxy ----------> IIS6/win2k3
> 
> Having a bit of an issue with keeping this connection alive.  It's a 
> simple
> set-up:
> 
> ProxyRequests Off
> #ProxyTimeout
> ProxyPreserveHost off
> <Proxy *>
> Order Deny,Allow
> Allow from all
> </Proxy>
> ######################################################################
> ###### ProxyPass /portal ajp://machine2:7001/portal ProxyPassReverse 
> /portal ajp://machine2:7001/portal ProxyPass /imageserver 
> http://image:7002/imageserver ttl=128 retry=300 ProxyPassReverse 
> /imageserver http://image:7002/imageserver
>     
> The ajp connection works just fine, the connection to image connects 
> and grabs images, but after awhile, images stop being served.
> 
> The backend image server is running IIS6 in standard mode on a windows 
> 2003 OS.
> 
> Apache Httpd.log excerpt:
> 
> [Fri Nov 17 14:34:10 2006] [info] Initial (No.1) HTTPS request 
> received for child 498 (server portal.test.com:443) [Fri Nov 17 
> 14:34:10 2006] [debug]
> mod_proxy_http.c(54): proxy: HTTP: canonicalising URL 
> //image:7002/imageserver/plumtree/common/private/js/jsutil/LATEST/PTDa
> teForm
> ats.js
> [Fri Nov 17 14:34:10 2006] [debug] proxy_util.c(1378): [client 
> 192.168.17.130] proxy: http: found worker 
> http://image:7002/imageserver for 
> http://image:7002/imageserver/plumtree/common/private/js/jsutil/LATEST
> /PTDat eFormats.js, referer: https://portal.test.com/portal/server.pt?
> [Fri Nov 17 14:34:10 2006] [debug] mod_proxy.c(756): Running scheme 
> http handler (attempt 0) [Fri Nov 17 14:34:10 2006] [debug]
> mod_proxy_http.c(1662): proxy: HTTP: serving URL 
> http://image:7002/imageserver/plumtree/common/private/js/jsutil/LATEST
> /PTDat
> eFormats.js
> [Fri Nov 17 14:34:10 2006] [debug] proxy_util.c(1798): proxy: HTTP: 
> has acquired connection for (image) [Fri Nov 17 14:34:10 2006] [debug]
> proxy_util.c(1858): proxy: connecting
> http://image:7002/imageserver/plumtree/common/private/js/jsutil/LATEST
> /PTDat eFormats.js to image:7002 [Fri Nov 17 14:34:10 2006] [debug]
> proxy_util.c(1951): proxy: connected
> /imageserver/plumtree/common/private/js/jsutil/LATEST/PTDateFormats.js 
> to
> image:7002 [Fri Nov 17 14:34:10 2006] [debug] proxy_util.c(2141): proxy:
> HTTP: connection complete to 192.168.17.131:7002 (image) [Fri Nov 17 
> 14:34:10 2006] [debug] mod_proxy_http.c(1541): proxy: header only [Fri 
> Nov
> 17 14:34:10 2006] [debug] proxy_util.c(1816): proxy: HTTP: has 
> released connection for (image) [Fri Nov 17 14:34:10 2006] [info] 
> [client 192.168.17.130] Connection closed to child 498 with unclean 
> shutdown (server
> portal.mda.mil:443) [Fri Nov 17 14:34:10 2006] [debug]
> mod_proxy_http.c(1541): proxy: header only [Fri Nov 17 14:34:10 2006] 
> [debug] proxy_util.c(1816): proxy: HTTP: has released connection for 
> (image) [Fri Nov 17 14:34:10 2006] [info] [client 192.168.17.130] 
> Connection closed to child 496 with unclean shutdown (server 
> portal.mda.mil:443)
> 
> 
> R. Rosado
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> ---------------------------------------------------------------------
> The official User-To-User support forum of the Apache HTTP Server Project.
> See <URL:http://httpd.apache.org/userslist.html> for more info.
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>    "   from the digest: users-digest-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 
> 
> 

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message