httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Serge Dubrouski" <serge...@gmail.com>
Subject Re: [users@httpd] RE: Apache/Tomcat request hangs intermittently
Date Mon, 02 Oct 2006 17:44:23 GMT
Can you post "connectors" part of your Tomcat's server.xml and your
workers.properties?

On 10/2/06, Durbha Murali - mdurbh <Murali.Durbha@acxiom.com> wrote:
>
>
>
>
> Can anyone help me out with this please?  I'm just completely stuck.
>
> Thanks
>
>
>
>
>
>  ________________________________
>
>
> From: Durbha Murali - mdurbh
>  Sent: Friday, September 29, 2006 4:06 PM
>  To: 'users@httpd.apache.org'
>  Subject: RE: Apache/Tomcat request hangs intermittently
>
>
>
>
>
> Just to add to this, I'm also getting the following error in tomcat
> connector's mod_jk.log
>
>
>
> [Fri Sep 29 14:37:26 2006] [1605:50880] [error]
> ajp_get_reply::jk_ajp_common.c (1531): Tomcat is down or refused connection.
> No response has been sent to the client (yet)
>
> [Fri Sep 29 15:12:42 2006] [1610:50880] [error]
> ajp_connection_tcp_get_message::jk_ajp_common.c (961):
> Can't receive the response message from tomcat, network problems or tomcat
> is down (139.x.x.x:8009), err=-110
>
> [Fri Sep 29 15:12:42 2006] [1610:50880] [error]
> ajp_get_reply::jk_ajp_common.c (1531): Tomcat is down or refused connection.
> No response has been sent to the client (yet)
>
>  ________________________________
>
>
> From: Durbha Murali - mdurbh
>  Sent: Friday, September 29, 2006 2:44 PM
>  To: 'users@httpd.apache.org'
>  Subject: Apache/Tomcat request hangs intermittently
>
>
>
> We have a webserver with Apache 2.2.2 running that acts as a pass-thru,
> forwarding all  POST requests from the internet to Tomcat.
>
> The connection works but sometimes, a request on the webserver just hangs.
> If I re-try a few times, the webpage eventually opens.  I'm not quite sure
> what is causing this.  If I bounce Apache, it works normally for a few hours
> and the problem starts again.  For  Debug Loglevel, I get the following
> errors in error_log.  I'm not quite sure if this has anything to do with my
> problem –
>
>
>
> [Fri Sep 29 11:07:46 2006] [info] [client 10.x.x.x] (32)Broken pipe:
> core_output_filter: writing data to the network
>
> [Fri Sep 29 11:07:51 2006] [info] [client 10.x.x.x] (104)Connection reset by
> peer: core_output_filter: writing data to the network
>
> [Fri Sep 29 11:07:51 2006] [info] [client 10.x.x.x] (32)Broken pipe:
> core_output_filter: writing data to the network
>
> [Fri Sep 29 11:08:10 2006] [info] [client 10.x.x.x] (104)Connection reset by
> peer: core_output_filter: writing data to the network
>
> [Fri Sep 29 11:08:10 2006] [info] [client 10.x.x.x] (32)Broken pipe:
> core_output_filter: writing data to the network
>
> [Fri Sep 29 11:08:25 2006] [info] [client 10.x.x.x] (104)Connection reset by
> peer: core_output_filter: writing data to the network
>
> [Fri Sep 29 11:08:25 2006] [info] [client 10.x.x.x] (32)Broken pipe:
> core_output_filter: writing data to the network
>
> [Fri Sep 29 11:09:18 2006] [info] [client 10.x.x.x] (104)Connection reset by
> peer: core_output_filter: writing data to the network
>
> [Fri Sep 29 11:09:18 2006] [info] [client 10.x.x.x] (32)Broken pipe:
> core_output_filter: writing data to the network
>
>
>
>
>
> When I do a netstat –a on the webserver, I see that the connection has been
> established, but my browser just keeps spinning and spinning.
>
>
>
> tcp        0      0 *:8000                      *:*
> LISTEN
>
> tcp        0      0 <webserver>:8000 ::ffff:<mylocalIP>:1757    ESTABLISHED
>
>
>
> This is our Production website.  Can someone please help me out?
>
>
>
> Thanks very much.
>
> Murali
>
>
> *************************************************************************
> The information contained in this communication is confidential, is
> intended only for the use of the recipient named above, and may be
> legally privileged.
>
> If the reader of this message is not the intended recipient, you are
> hereby notified that any dissemination, distribution or copying of this
> communication is strictly prohibited.
>
> If you have received this communication in error, please resend this
> communication to the sender and delete the original message or any copy
> of it from your computer system.
>
> Thank you.
> *************************************************************************
>
>

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message