httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From masro <>
Subject Re: [users@httpd] Cannot Start HTTPD Service
Date Fri, 13 Oct 2006 07:12:35 GMT

you have to customize your 2.0.59/bin/envvars it looks like that is not found for linking in LD_LIBRARY_PATH,


. /usr/bin/envvars  
ldd /usr/bin/httpd


Nick Kew schrieb:
> On Thursday 12 October 2006 17:31, Bjorgen T. Eatinger wrote:
>> Whenever I try starting the httpd service, I get the following error:
>> [root@log]# service httpd start
>> Starting httpd: /usr/sbin/httpd: error while loading shared libraries:
>> cannot open shared object file: No such file or
>> directory [FAILED]
> So presumably you compiled it (either all of apache or one or
> more module you're loading) against that library.
>> I've obtained and installed the very latest openldap (v2.3) and it did
>> NOT install this library.  I have no idea why Apache needs this library
>> in the first place.
>> Any ideas as to how I can fix this?  We are dead in the water not being
>> able to start the server.
> Are you using ldap?  If so, just compile apr and apache using the library 
> versions you do have installed.  If not, just don't load the ldap modules.
> Or if necessary recompile without ldap support.

The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:> for more info.
To unsubscribe, e-mail:
   "   from the digest:
For additional commands, e-mail:

View raw message