httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomasz Chmielewski <...@syneticon.net>
Subject [users@httpd] mod_deflate in 2.2.3 - doesn't work properly for PHP - or does it?
Date Wed, 04 Oct 2006 13:37:56 GMT
I'm just moving a web server to a new one (old one: Apache 2.0.x, PHP 
4.x, MySQL 4.x; new one: Apache 2.2.3, PHP 5.x, MySQL 5.x etc.).

One thing that works differently is mod_deflate - I'm not sure if it 
works properly for PHP pages.


mod_deflate configuration look like that on both servers:

# use compression
SetInputFilter DEFLATE
SetOutputFilter DEFLATE

DeflateFilterNote Input instream
DeflateFilterNote Output outstream
DeflateFilterNote Ratio ratio
<IfModule mod_deflate.c>
LogFormat '"%r" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
</IfModule>


However, the logs on a new server show that PHP pages are not 
compressed, and everything else is compressed:

"GET /wiki/index.php/CUPS_troubleshooting HTTP/1.1" -/- (-%)
"GET /phpMyAdmin/favicon.ico HTTP/1.1" 6569/18886 (34%)


The old server show the pages are compressed - ratio is other than "-" 
and shows numbers:

"GET /wiki/index.php/Related_projects HTTP/1.1" 3707/12099 (30%)


Why doesn't Apache 2.2.3 show compression ratios for PHP pages?

When I checked with Wireshark, the pages are indeed compressed.

How can I make sure that the ratios are shown in the log?

php.ini on both servers look exactly the same.


-- 
Tomasz Chmielewski
http://wpkg.org

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message