httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Mabe" <davem...@gmail.com>
Subject Re: [users@httpd] Apache Sometimes Ignoring MaxSpareServers, Running Out of Memory
Date Sun, 24 Sep 2006 01:51:04 GMT
On 9/22/06, Dave Mabe <davemabe@gmail.com> wrote:
> On 9/22/06, Joshua Slive <joshua@slive.ca> wrote:
> > On 9/22/06, Dave Mabe <davemabe@gmail.com> wrote:
> > > I'm running Apache from the apache-perl Debian package out of stable.
> > >
> > > Every so often (just infrequently enough to be very annoying), Apache will
> > > all of the sudden ignore the MaxSpareServers and start up more and more
> > > Apache child processes until it brings the server down.  During normal
> > > operation, it works just fine.  But when it gets in this state, it brings
> > > the server to its knees and I have to reboot.
> > >
> > > I'm using this version of apache-perl: 1.3.33-6sarge1
> > >
> > > Any ideas about how to troubleshoot and fix this problem?
> >
> > What does server-status look like during these times (see mod_status)?

OK, the problem happened again and I was able to pull some information
from server-status.

First of all, here's the appropriate part of my config:

MinSpareServers 3
MaxSpareServers 5
StartServers 3
MaxClients 50
MaxRequestsPerChild 30

I've attached a few files:
* server-status.normal.htm - the output from server-status during
normal operation
* server-status.problem.htm - output from server-status as soon as I
detected the problem
* server-status.problem.escalating.htm - output from server-status a
few minutes later
* process.list.txt - output from ps -ef|grep apache during the problem

As you can see from process.list.txt, Apache is completely ignoring
MaxSpareServers and creating a ton of child processes until it
completely runs out of memory.  Sometimes it gets in this state a
couple times a day, other times it will go for 10 days without the
problem occuring.

Any idea what is going on and how I might be able to fix it or
troubleshoot further?

Thanks!
Dave

Mime
View raw message