httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben <...@redsnapper.net>
Subject Re: [users@httpd] compilation problem
Date Mon, 18 Sep 2006 15:47:48 GMT
I've seen this error before.
It's because the current /usr/apache directory is causing some sort  
of config problem

Try this -

mv /usr/apache /usr/apache.x
./configure --prefix=/usr/apache  --enable-proxy --enable-cache -- 
enable-disk-cache
make
mv  /usr/apache.x /usr/apache
make install


-- should sort you out.


On 18 Sep 2006, at 16:32, Hasson Yehudit wrote:

> Hi
>
> I have a compilation problem while trying to compile the apache second
> time with different configuration:
>
> My steps are:
>
> 1)  ./configure --prefix=/usr/apache  --enable-proxy --enable-cache
> --enable-disk-cache
> 2)   make
> 3)  make install
> 4)  ./configure --prefix=/usr/apache  --enable-proxy --enable-cache
> --enable-mem-cache
> 5) make
>
> I gets the following error:
>
> .....
>   exports.c:1141: `ap_hack_apr_xml_parser_feed' previously defined  
> here
> exports.c:2563: redefinition of `ap_hack_apr_xml_parser_done'
> exports.c:1142: `ap_hack_apr_xml_parser_done' previously defined here


---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message