httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Williams <stephen.willi...@highwind.com>
Subject Re: [users@httpd] running apache 1.3.31 & 1.3.37 on the same server
Date Fri, 29 Sep 2006 14:09:50 GMT

>You give no details of your setup so I have to assume the obvious; that
>you are trying to run both apaches on the same socket (ie, same IP and
>port). You have to have the apaches "Listen" to different TCP/IP
>sockets, eg:
>
>Different ports:
>Apache #1:
>Listen 80
>
>Apache #2
>Listen 8080
>
>Different IPs:
>Apache #1:
>Listen 192.168.1.1
>
>Apache #2
>Listen 192.168.1.10
>
>or a combination..
>
>Rgds,
>Owen Boyle
>Disclaimer: Any disclaimer attached to this message may be ignored. 
>  
>
Owen,

I have tried that sorry for the vague question. The thing that's odd is 
that when I try to start the second instance of apache it sees (seems 
aware) of the other instance. It actually sees the others PID file and I 
have explicit paths in the conf with different names. This is why I am 
so lost on this one, if the thing is named different and running on a 
separate port how can it know about the other?

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message