httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Tunstall" <john.tunst...@btinternet.com>
Subject Re: [users@httpd] Apache and router
Date Mon, 04 Sep 2006 10:08:20 GMT
Hi Steve. Thanks for your help on this.

Do you have an idea what the CGI script is that controls the IP address to be used?

Thanks again.

JohnT
  ----- Original Message ----- 
  From: Steve Swift 
  To: users@httpd.apache.org 
  Sent: Monday, September 04, 2006 8:06 AM
  Subject: Re: [users@httpd] Apache and router


  Well, you will probably have to inspect the CGI script that handles /cgi-bin/ai to see why/if
it is returning http://192.168.0.2 amongst its output

  If I were to guess, I'd say that the CGI script is trying to determine the address of the
server in order to generate URL's that refer to the server. If it did this, then of course
it would come up with 192.168.0.2 since that *is* the address of the server.  

  If your CGI script is doing this then it would be far better if it used relative URL's rather
than fully-qualified ones.


  On 03/09/06, John Tunstall <john.tunstall@btinternet.com> wrote:

    Jim. Thanks for the reply. Thats the problem. The static Ip address is in
    the first two urls but the url flips to that of the router as soon as a
    booking request is made from the outside to the server behind the router. 
    Any ideas how Apache being used with Windows XP can be structured to
    overcome this and retauin the static IP that you see in the early screens
    below? Is it a config problem; a router proble; or what?
    Any help gratefully received. 

    John T
    ----- Original Message -----
    From: "Jim Walls" <k6ccc@earthlink.net>
    To: <users@httpd.apache.org >
    Sent: Sunday, September 03, 2006 5:32 PM
    Subject: Re: [users@httpd] Apache and router


    > John Tunstall wrote:
    >> Hi. I have a problem!
    >>  I am using Apache along with a software system on a server at a club. 
    >> The system is accessed over Internet to make bookings. There is a router
    >> in between the club LAN and the Internet. There is a static IP address
    >> for the server. The first message from the Internet to the club that 
    >> activates two introductory screens works fine and you will see an example
    >> with amended - for security reasons -  IP addresses below. The first
    >> interaction from the customer, when booking details are sent to the 
    >> server over Internet, causes the http IP address to change to that of the
    >> router after which the booking sequence falls over because the server can
    >> no longer be accesed over Internet.
    >>
    >> USING WEB ADDRESS
    >>
    >> First screen
    >>
    >> http://www.xxx.
    >>
    >>
    >> 2ndscreen
    >>
    >>   http://www.xxx/cgi-bin
    >>
    >>
    >> 3rd screen where problem begins and router IP address is substituted
    >>
    >> http://192.168.0.2/cgi-bin/ai 
    >>
    >
    > Sure will cause a problem!  You are using an address that can not EVER be
    > accessed via the internet.  Your 192.168... address is the NATed address
    > on your LAN, and is in one of the private IP ranges that works fine on a 
    > local LAN, but not on the internet.  For someone to access your server
    > from the internet, they must specify (or follow a link to) a public IP
    > address (the WAN side of your router), or a URL that can point to public 
    > IP address via DNS.
    >
    > --
    > 73
    > -------------------------------------
    > Jim Walls - K6CCC
    > k6ccc@amsat.org
    > Ofc:  818-548-4804
    > http://home.earthlink.net/~k6ccc
    > AMSAT Member 32537 - WSWSS Member 395
    >
    >
    > --------------------------------------------------------------------- 
    > The official User-To-User support forum of the Apache HTTP Server Project.
    > See <URL:http://httpd.apache.org/userslist.html> for more info.
    > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
    >   "   from the digest: users-digest-unsubscribe@httpd.apache.org 
    > For additional commands, e-mail: users-help@httpd.apache.org
    >
    >
    >
    > --
    > No virus found in this incoming message.
    > Checked by AVG Free Edition. 
    > Version: 7.1.405 / Virus Database: 268.11.7/436 - Release Date: 01/09/2006
    >
    >


    ---------------------------------------------------------------------
    The official User-To-User support forum of the Apache HTTP Server Project. 
    See <URL:http://httpd.apache.org/userslist.html> for more info.
    To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org 
       "   from the digest: users-digest-unsubscribe@httpd.apache.org
    For additional commands, e-mail: users-help@httpd.apache.org





  -- 
  Steve Swift
  http://www.swiftys.org.uk 


------------------------------------------------------------------------------


  No virus found in this incoming message.
  Checked by AVG Free Edition.
  Version: 7.1.405 / Virus Database: 268.11.7/436 - Release Date: 01/09/2006

Mime
View raw message