httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] can php module be compiled like this
Date Tue, 15 Aug 2006 02:28:35 GMT
On 8/14/06, g xy <gxy.apache@gmail.com> wrote:
>
> Hi,All
>      I now meet a very difficult envirenment. I have a apache http server
> running which was originally compiled without DSO support, now I want to
> substitute the php module to let it include new version of mysql client. How
> should I do ? can I compile it with another apxs and then copy the installed
> php to my apache server and then modify the httpd.conf to load new module? I
> tried this way and when I tried to start apache, it says can't load php4.so?
> what else should I do ? can anyone help me? Thanks!

If your apache httpd was not originally compiled with mod_so included,
then there is no way to load dso modules.  You will need to recompile
apache httpd, either to add mod_so, or to simply change your php
module.

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message