httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] Browser seems to do a loop when the redirect runs
Date Fri, 11 Aug 2006 20:07:49 GMT
On 8/11/06, José Euclides Silva Junior <euclidesjr2005@gmail.com> wrote:
>
> Hi guys,
> i am back with those questions about redirect directive... As Steve taught
> me to do, my http.conf is the following:
> ServerName www-pddataprev
>    DocumentRoot
> /u01/app/oracle/product/oracle10g/Apache/Apache/htdocs/deqs_web/
>    # DocumentRoot /u01/app/oracle/product/oracle10g/j2ee
>    RewriteEngine on
>    RewriteRule ^(.*) http://10.0.134.23:7778/deqs/ [P,L]
>
> But, whenever the RewriteRule runs both mozzila and ie seems to do a loop,
> since the memory size and cpu time increases very much. However the web page
> isnt loaded.

I'm very hesitant to get into this thread, because you seem to be
trying to do complicated stuff without fully reading the documentation
or understanding what is going on on your server.

Proxying back to your own server is silly -- it wastes tons of
resources.  But if you are going to do it, you can prevent the loop by
preceding the RewriteRule with a
RewriteCond %{Request_URI} !^/deqs

Better solutions would be:
- reconfigure your j2ee directives to act directly at the root of the
server rather than on the url /deqs.  Check your app server docs for
instructions
- Use an internal redirect rather than a proxy:
RewriteRule (.*) /deqs$1 [PT,L]

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message