httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Slive" <jos...@slive.ca>
Subject Re: [users@httpd] mod_rewrite issue
Date Tue, 01 Aug 2006 21:39:41 GMT
On 8/1/06, SOPRO <soprobr@gmail.com> wrote:
> Hi friends!
>
> I have an aplication hosted on a JBOSS server that must receive an id
> as argument.
> This id will make the application load the correct template for the typed URL.
>
> Eg.: For URL 'client1.app.mydomain.com', the application will load the
> template for 'client1'.
>
> I trying to do something like this:
>
> <VirtualHost *:80>
>     ServerName www.app.mydomain.com
>     ServerAlias *.app.mydomain.com
>
>     RewriteCond %{http_host} ^(.*).app.mydomain.com
>     RewriteRule ^(.*) http://localhost:8080/app?id=%1 [P,L]
> </VirtualHost>
>
> The problem is that I get a redirect to
> 'http://localhost:5050/app?id=client1' and I want to keep the original
> URL (client1.app.mydomain.com).

What does the RewriteLog say when you configure it?  Do you have
mod_proxy and mod_proxy_http included in the server?  Are you sure it
is not the app server sending the redirect?  (Have you done a packet
trace?)

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message