httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian P Blackburn <iblac...@csc.com>
Subject Re: [users@httpd] No Form data being passed to Scripts
Date Mon, 21 Aug 2006 14:37:59 GMT




Hi

The html form tag is :

<FORM  METHOD="POST" ACTION="/cgi-bin/bom_report.ksh">

The korn shell script bom_report.ksh reads in the parameters from stdin
using the unix function "read" which reads input from standard input
and then assigns it to a variable,

read Arg1

Then a post-query executable decodes the string which was assigned to the
variable "Arg1".




cheers

Ian Blackburn




                                                                           
             "Joshua Slive"                                                
             <joshua@slive.ca>                                             
                                                                        To 
                                       users@httpd.apache.org              
                                                                        cc 
                                                                           
                                                                   Subject 
                                       Re: [users@httpd] No Form data      
                                       being passed to Scripts             
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           




On 8/21/06, Ian P Blackburn <iblackbu@csc.com> wrote:

> I have a utility I have deployed to a HP-UX webserver which has both
Apache
> 2 & Apache 1.3.
> The utility accepts parameters populated on a html form which is
submitted
> and the
> values of this form is used to run a ksh script.  However, when this html
> page is loaded using
> Apache 2 there are no values being passed from the html form POST action.
> If I load the page
> using Apache 1.3 it works perfectly.

Show us the simplest possible script that demonstrates the problem.
Personally, I can't imagine how you are accessing POST parameters from
a ksh script.  How are you reading and decoding standard input?

Joshua.

---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org




---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
   "   from the digest: users-digest-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message